Overview Features Coding Performance Forum Downloads Products OrderV4 Contact

Welcome to the Apollo Forum

This forum is for people interested in the APOLLO CPU.
Please read the forum usage manual.



All TopicsNewsPerformanceGamesDemosApolloVampireAROSWorkbenchATARIReleases
Documentation about the Vampire hardware

Wiz Game Demo - Anyone Made It Working?

Michal Pietal

Posts 223
30 Jan 2021 10:47



Hi,

I am attempting to try Wiz demo.  It's an adf file to be downloaded from vendor's site.

The vendor says it needs Amiga FFS file system when not loading directly via floppy.

What I tried yet:
- launch the demo from OS 1.3 (mount / click)
- launch the demo from OS 3.x / ApollOS (mount / click)
- install the demo on OS 3.x / ApollOS (mount / install / run), according to the instructions

Every time what I get is an "insert disk 2" prompt or system halt.

Anyone managed to run this game on Vampire Standalone?  If so, please share Your setup please.


Tim Noyce

Posts 100
30 Jan 2021 17:58


Michal Pietal wrote:

  Hi,
 
  I am attempting to try Wiz demo.  It's an adf file to be downloaded from vendor's site.
 
  The vendor says it needs Amiga FFS file system when not loading directly via floppy.
 
  What I tried yet:
  - launch the demo from OS 1.3 (mount / click)
  - launch the demo from OS 3.x / ApollOS (mount / click)
  - install the demo on OS 3.x / ApollOS (mount / install / run), according to the instructions
 
  Every time what I get is an "insert disk 2" prompt or system halt.
 
  Anyone managed to run this game on Vampire Standalone?  If so, please share Your setup please.

I have the two ADF files for the game, and had to use the WHDLoad installer to get around that 'insert disk 2' issue. You also have to make certain you're running in turtle mode, or you may get an 'unrecognized CPU" warning when you try to run it. I can't recall right now whether it also requires using the AOS ROM rather than the AROS one.




Tim Noyce

Posts 100
30 Jan 2021 18:07


Looks like it runs on Apollo OS, though I see a DOS Error #205 when I start it. Still runs though. Also see an error when I quit using the WHDload quit key. Same two scripts work without issue under Coffin.



Tim Noyce

Posts 100
30 Jan 2021 18:59


Same with their other two disk title I own, "Tin Toy Adventure". Use the WHDLoad installer.

Although you CAN mount an ADF file, you can't get to the utility to change or add another ADF image once you've launched these games.



Michal Pietal

Posts 223
31 Jan 2021 10:42


Tim Noyce wrote:

Looks like it runs on Apollo OS, though I see a DOS Error #205 when I start it. Still runs though. Also see an error when I quit using the WHDload quit key. Same two scripts work without issue under Coffin.
 

Dear Tim,

Can you quote your running setup?

- do you mount an ADF and click the icon?
- or rather, you install the files on HDD, according to the instructions and then run the game?
- or other way?

Furthermore, are you talking about the demo version, too?


Tim Noyce

Posts 100
31 Jan 2021 16:04


I bought the full version as a digital download, which is two ADF files. The demo is a single file, and didn't work for me unfortunately. The full version didn't work when I attempted to run it either - as there's no way to mount disk 2 once the game starts to load. I tried mounting both ADF files - that didn't do it either - so apparently the game code doesn't handle multi-drive setups. I tried the quick & easy install - simply copying the entire contents of both ADF files to the same folder. Unfortunately, that didn't do it either. Still was asking for Disk 2, even though all the files were in the same folder. When I used the WHDLoad install script which went through the same proces (copies two disks to the same folder) and apparently does something else in the environment behind the scenes, it works. I don't believe there's a WHDLoad install script for the demo file unfortunately, though I've not checked.

 


Maurizio Tirone

Posts 45
31 Jan 2021 17:59


I played the original floppy version on V1200 with no problem ...


Michal Pietal

Posts 223
31 Jan 2021 18:53


Maurizio Tirone wrote:

I played the original floppy version on V1200 with no problem ...

Classics Amigas make no problems.

V4SA makes a problem.

Hence, the thread.


Manos Sg

Posts 74
31 Jan 2021 20:01


On V4 the WHDLoad Wiz game plays quite ok, apart from some (annoying but easy to ignore) artifacts on the left side of the screen.


Michal Pietal

Posts 223
01 Feb 2021 16:06


But you're talking about the full game version, not the demo, right?


Manos Sg

Posts 74
01 Feb 2021 17:42


Yes, apparently, sorry for not clarifying.

posts 11