Overview Features Coding Performance Forum Downloads Products OrderV4 Contact

Welcome to the Apollo Forum

This forum is for people interested in the APOLLO CPU.
Please read the forum usage manual.



All TopicsNewsPerformanceGamesDemosApolloVampireAROSWorkbenchATARIReleases
Documentation about the Vampire hardware

V1200 HD Activity Lightpage  1 2 

Michael Huck

Posts 50
12 Mar 2020 19:37


Hi all

Newbie question, how do I set up the card so the HD activity light comes on when using V1200  IDE?

Cheers

Michael


Francesco Lemmi

Posts 50
12 Mar 2020 22:08


You can't at the moment


Michael Huck

Posts 50
12 Mar 2020 22:33


Ok thanks. Any idea how I fix the mouse pointer which is a little off


Sean Sk

Posts 421
12 Mar 2020 22:44


Michael Huck wrote:

Any idea how I fix the mouse pointer which is a little off

 
Grab vampiregfx.card that comes with the latest cores and throw it into the LIBS:Picasso96 folder. Then reboot.
 


Michael Huck

Posts 50
13 Mar 2020 01:49


sean sk wrote:

Michael Huck wrote:

  Any idea how I fix the mouse pointer which is a little off
 

 
  Grab vampiregfx.card that comes with the latest cores and throw it into the LIBS:Picasso96 folder. Then reboot.
 

Cool thanks Iíll try that at the weekend


Krzysztof AT

Posts 38
13 Mar 2020 09:54


Hello

In My A2000 i have connected led with using pin39 an 41 and resistor 330ohm  (i think in pin39. Doesn't have acces to my Amiga to check for sure). It's simple to made, a d working fine in A2000. Maybe might work in A1200 also. Scheme should be somwhere in that forum or youtube. Just try to search "HDD activity led A2000".


Michael Huck

Posts 50
13 Mar 2020 12:37


Krzysztof AT wrote:

Hello
 
  In My A2000 i have connected led with using pin39 an 41 and resistor 330ohm  (i think in pin39. Doesn't have acces to my Amiga to check for sure). It's simple to made, a d working fine in A2000. Maybe might work in A1200 also. Scheme should be somwhere in that forum or youtube. Just try to search "HDD activity led A2000".

Appreciate that, Iím not gonna mess with it though Iíll wait until I can buy something ready Made


Tim Noyce

Posts 97
13 Mar 2020 14:03


I had to do a similar fix when I put the IDE-CF adapter in my A1200 a couple years ago. So far, has worked flawlessly.


Francisco Rabay Junior

Posts 2
14 Mar 2020 20:44


Hello,
  There is the IDELED for Amiga 500, by Eduardo Arana (Arananet).
  Connect to pin 39 of the CF Adapter, and place the IDELED adapter on the Keyboard connector. But you have the Amiga 1200. I think it will not work.

 
  EXTERNAL LINK   


Eberhard Blum

Posts 8
15 Mar 2020 01:47


Michael Huck wrote:

          Hi all
         
          Newbie question, how do I set up the card so the HD activity light comes on when using V1200  IDE?
         
          Cheers
         
         
          Michael
         

         
          It is possible with a little modification.
         
      Just cut the ground line on the original A1200 LED Circuit Board located in the upper plastic Case e.g. with a screwdriver. Cut it between HDD and Floppy/Power, then solder that seperated third of the ground line with an extra cable to the V1200 HDD GND, The HDD+ Cable has to be cut as well, disconnected from the original plug, and goes from the corresponding LED to the V1200 as well. The remaining three stock wires stay in their original plug and still go to the A1200 Mainboard.
         
          And there you go, full functionality!!
         


Henryk Richter
(Apollo Team Member)
Posts 128/ 1
15 Mar 2020 07:50


There are several ways to accomplish this.

One is a cable from the second pin of the Vampire1200 (HDD-) to Pin39 of the Mainboard connector (already mentioned in this thread).

Second: the upcoming Bifrost special edition will have additional inputs.

Third: From what I've heard Arana is going to sell LED modules with an auxiliary input.

Also: I've open-sourced my approach that uses a little PCB on top of the mainboard LED connector snd allows to show activity of the Vampire IDE and mainboard IDE in parallel. EXTERNAL LINK 



Reuben Barnett

Posts 2
19 Feb 2021 11:42


I just put back my CF-HDD on the V2 Vampire board since the latest 2.13 Gold allows it to function again. However there's no working HDD activity light externally on my A1200.
 
So the solutions you described above Henryk are the only way I assume? The plug and soldered wire looks simple enough. Although my knowledge of electronics and soldering are pretty much nil. Might have to get someone locally to make the modification.
 
  Thanks. :)


Jd 64

Posts 20
19 Feb 2021 13:37


@Henryk - What does the C1 100nf capacitor on your board do & why is it optional?



Darren Eveland

Posts 48
22 Feb 2021 01:39


@Henryk, I am trying to get your little PCB built on mypcbway for my personal A1200/V1200 system,  but they are asking for a BOM that has exact part numbers and quantities.  Would you be able to provide that?

Thank you.


Mateusz S.

Posts 53
22 Feb 2021 01:59


I would also like to know it. Is there a manualna on how to connect both Amiga IDE and V IDE to single led?


Henryk Richter
(Apollo Team Member)
Posts 128/ 1
22 Feb 2021 20:29


The capacitor is literally just for fun. If populated, it will cause a delay to the LED switching off, i.e. depending on capacitance a soft afterglow should somebody dislike rapid blinking.


Henryk Richter
(Apollo Team Member)
Posts 128/ 1
22 Feb 2021 20:35


Darren Eveland wrote:

@Henryk, I am trying to get your little PCB built on mypcbway for my personal A1200/V1200 system,  but they are asking for a BOM that has exact part numbers and quantities.  Would you be able to provide that?

I've never even thought about having that PCB populated by a factory because it's so simple. You just need 3 SMD components and 11 THT soldering points.

Due to the fact that the 5x1 socket strip needs to be mounted from the bottom side while the other parts are mounted on the top, I'd expect some raised eyebrows (in terms of extra charges) by potential manufacturers.


Darren Eveland

Posts 48
23 Feb 2021 15:04


Henryk Richter wrote:

Darren Eveland wrote:

  @Henryk, I am trying to get your little PCB built on mypcbway for my personal A1200/V1200 system,  but they are asking for a BOM that has exact part numbers and quantities.  Would you be able to provide that?
 

  I've never even thought about having that PCB populated by a factory because it's so simple. You just need 3 SMD components and 11 THT soldering points.
 
  Due to the fact that the 5x1 socket strip needs to be mounted from the bottom side while the other parts are mounted on the top, I'd expect some raised eyebrows (in terms of extra charges) by potential manufacturers.

It's only $30 to have pcbway assemble it.  I don't have the steady hands to solder very small smd components.  If you can suggest to me a parts list that would be appreciated.  Unless someone knows some retro store or place selling pre-assembled boards? 

thanks
Darren


Jd 64

Posts 20
23 Feb 2021 16:18


Henryk Richter wrote:

The capacitor is literally just for fun. If populated, it will cause a delay to the LED switching off, i.e. depending on capacitance a soft afterglow should somebody dislike rapid blinking.

Thanks. Just one other question as I'm about to assemble one. Which value resistor goes on R1 & R2? Your page mentions 4.7k & 10k resistors but doesn't say where each go?



Henryk Richter
(Apollo Team Member)
Posts 128/ 1
24 Feb 2021 07:59


Patrick Hawkins wrote:

  Thanks. Just one other question as I'm about to assemble one. Which value resistor goes on R1 & R2? Your page mentions 4.7k & 10k resistors but doesn't say where each go?

R1=10k, R2=4.7k. You can also populate both with 4.7k, which might work better in some (rare) cases of CF cards.

Please note that there are also devices available which are not compatible with 5V systems wrt. HDD LEDs. I'm aware of SD-IDE adapters which have internal pull-ups to 3.3V (instead of open drain / open collector) and will cause the LED to glow permanently. That happens on the internal connector as well as my LED adapter. I do have a workaround for those but did not draw a new PCB as of yet.

posts 24page  1 2