Overview Features Coding Performance Forum Downloads Products OrderV4 Contact

Welcome to the Apollo Forum

This forum is for people interested in the APOLLO CPU.
Please read the forum usage manual.



All TopicsNewsPerformanceGamesDemosApolloVampireAROSWorkbenchATARIReleases
Questions and Answers for AROS AMIGA OS

ScummVM On V4

Manos Sg

Posts 74
15 Dec 2020 17:44


Hello, fellow vampires.

I just got my V4 today and, what a sad surprise, ScummVM only plays with very sloooooow audio. Is there a way to fix this?

Also, what emulators work in ApollOS for Amstrad CPC and C64?


Maurizio Tirone

Posts 45
16 Dec 2020 11:15


I'm a V1200 user I don't have a V4, but what I can tell you about ScummVM is that you always have to find the right compromise between AHI and the type of graphics chosen for the game.


James Husted

Posts 70
16 Dec 2020 11:28


Hey there, I use ScummVM on V2 and V4 for the first 2 monkey island games, the indiana Jones games and Beneath a Steel Sky... I have no issues. What OS are you using?


Manos Sg

Posts 74
16 Dec 2020 18:44


Hi, guys, and thank you for the answers.

Maybe I need to experiment with the AHI? I think this should work out of the box. :S

@James I use ApollOS.

Maybe I delete the emulator and install a different version of ScummVM RTG?


Maurizio Tirone

Posts 45
16 Dec 2020 20:23


Keep in mind that ScummVM works much better on a clean 3.1 than on Coffin ... I don't know how it works on ApolloOS, but AHI has to be set and the ScummVM preferences themselves have to be set game by game.


Manos Sg

Posts 74
16 Dec 2020 21:16


Maurizio Tirone wrote:

Keep in mind that ScummVM works much better on a clean 3.1 than on Coffin ... I don't know how it works on ApolloOS, but AHI has to be set and the ScummVM preferences themselves have to be set game by game.

Thanks, Maurizio, I tried quite a few AHI settings as well as the ScummVM preferences, but, unfortunately, I got no joy. :(


James Husted

Posts 70
17 Dec 2020 10:20


not true on my V2 its coffin that I use.


Pedro Cotter
(Apollo Team Member)
Posts 302
17 Dec 2020 12:33


Hi
Try setting Unit 0/1 in AHI prefs to 27429 Hz
Im not sure which Unit Scumm uses


Manos Sg

Posts 74
17 Dec 2020 19:34


Hello, mate, thank you for your reply.
 
I tried setting both to 27429Hz, I get either no sound or a nice system crash. :(
 
Edit: It worked once after a lot of trial and error, but when I quit to launcher, it crashed again.

posts 9