Overview Features Coding Performance Forum Downloads Products OrderV4 Contact

Welcome to the Apollo Forum

This forum is for people interested in the APOLLO CPU.
Please read the forum usage manual.



All TopicsNewsPerformanceGamesDemosApolloVampireAROSWorkbenchATARIReleases
The team will post updates and news here

GOLD2.13 Release Candidatepage  1 2 3 4 5 6 7 

Sean Sk

Posts 430
18 Sep 2020 10:13


Hi Simo. Yeah it was the WHDLoad version.


Michele Carbonaro

Posts 4
19 Sep 2020 13:51


Hello everyone, with the 2.13 RC2 core I have encountered problems with the whdloads of bubble bobble and buggy boy, they run very fast.


Simo Koivukoski
(Apollo Team Member)
Posts 601
23 Sep 2020 17:07


DL link on the first post has been updated with the new V1200 core. A small turtle mode adjustment. Typically the best result with the WHDLOAD comes using combination of the NoCache + ExpChip + ChkInts -options and disabling the TCP/IP stack.


Michael AMike

Posts 150
24 Sep 2020 14:15


Thanks Simo :) What are the changes at the turtle mode? For CD32 emulation I use vcontrol:Turtle=1 FPU=0 AKIKO VBRMOVE=0. Should I change something? Thanks :)


Simo Koivukoski
(Apollo Team Member)
Posts 601
24 Sep 2020 14:55


No changes needed. Core update is mainly turtle-mode timing adjustment based on the feedback.


Michele Carbonaro

Posts 4
24 Sep 2020 20:40


Thanks Simo, bubble bobble and buggy boy are back to normal speed now I will continue to do other tests.


Simo Koivukoski
(Apollo Team Member)
Posts 601
30 Sep 2020 21:17


V1200 core is updated to the RC3 version with newer "dummy" 68040.library v40.3c. Lib contains now also the fast CopyMem routines (Bax/H.Hippenstiel). VampireMap/VampireFlash tools are also updated on the first post's DL link with this newer lib.


Michael AMike

Posts 150
01 Oct 2020 15:09


I can't keep up with the flashing - Thanks :)



Vito Leva

Posts 40
02 Oct 2020 08:55


Simo Koivukoski wrote:

 
 
  [GOLD2.13RC3] (xx.xx.202x)
  * Improved FMUL/FSQRT
  * fpsp080_FE00000_HW_FSQRT_09Aug20
  * A new reset proof PCR Turtle mode (VControl TU 2)
  * V-IDE controller enabled (V1200)
  * Improved chipmem access speed (V1200)
  * Akiko C2P implemented (V1200)
  * Updated EmuTOS ROM to version 1.0
  * 68040 "dummy" library v40.3c with the fast CopyMem (H.Hippenstiel)
 
  EXTERNAL LINK   
 
  e1: package is updated with the V600 core.
  e2: package is updated with the V1200 RC2 core.
  e3: All cores are updated with the EmuTOS 1.0 rom in package.
  e4: A small turtle mode adjustment for the V1200 core.
  e5: package is updated with the V1200 RC3 core.
 
 

 
  Hi, on Aminet i have seen that Holger Hippenstiel has updated CopyMemAIO to ver 4.2.....its the same of 68040 "dummy" library v40.3c or its an update?
  Bye.


Michele Carbonaro

Posts 4
03 Oct 2020 21:02


Hi Simo, with the RC3 core unfortunately the whdload speed problem has reoccurred.


Mister Jbam

Posts 4
03 Oct 2020 21:29


i have big speed problems with alien breed 3d.
you too?


Michele Carbonaro

Posts 4
03 Oct 2020 21:38


mister jbam wrote:

i have big speed problems with alien breed 3d.
  you too?

Hi, I only tried Bubble bobble and buggy boy.  Tomorrow I will try alien breed 3d.


Michael AMike

Posts 150
03 Oct 2020 21:44


Simo Koivukoski wrote:

V1200 core is updated to the RC3 version with newer "dummy" 68040.library v40.3c. Lib contains now also the fast CopyMem routines (Bax/H.Hippenstiel). VampireMap/VampireFlash tools are also updated on the first post's DL link with this newer lib.

The new V1200 x12 core is faster than the old 2.12 x13 core for the V600.:)
Jubimark V1200x12 46:33 minutes V600x13 46:53 Minutes
EXTERNAL LINK  So that's a new first place in the list.




Vito Leva

Posts 40
25 Oct 2020 15:13


Vito Leva wrote:

Simo Koivukoski wrote:

 
   
    [GOLD2.13RC3] (xx.xx.202x)
    * Improved FMUL/FSQRT
    * fpsp080_FE00000_HW_FSQRT_09Aug20
    * A new reset proof PCR Turtle mode (VControl TU 2)
    * V-IDE controller enabled (V1200)
    * Improved chipmem access speed (V1200)
    * Akiko C2P implemented (V1200)
    * Updated EmuTOS ROM to version 1.0
    * 68040 "dummy" library v40.3c with the fast CopyMem (H.Hippenstiel)
   
    EXTERNAL LINK   
   
    e1: package is updated with the V600 core.
    e2: package is updated with the V1200 RC2 core.
    e3: All cores are updated with the EmuTOS 1.0 rom in package.
    e4: A small turtle mode adjustment for the V1200 core.
    e5: package is updated with the V1200 RC3 core.
   
 

 
  Hi, on Aminet i have seen that Holger Hippenstiel has updated CopyMemAIO to ver 4.2.....its the same of 68040 "dummy" library v40.3c or its an update?
  Bye.

Now Holger Hippenstie has updated CopyMemAIO to ver 4.4...someone can explain if is the same thing or not?



Juan Jose

Posts 23
30 Dec 2020 23:06


Any news about the Core Gold 2.13?
The wait is eternal.


Allan Versaevel

Posts 100
31 Dec 2020 04:47


I too, await for new core :)


Igor Majstorovic
(Apollo Team Member)
Posts 405
31 Dec 2020 10:58


Why don't you flash some of the cores that are on first page and try them out?


Allan Versaevel

Posts 100
31 Dec 2020 17:42


I am curretnly running the latest, I believe, 2.13 RC3. I am happy with it, just curious when a final version would be available. You don't need to answer that since I know you guys are busy...


Darren Eveland

Posts 51
01 Jan 2021 22:59


Hi Simo, running Vampire 500 V2 Apollo rev 7645b x11 (Gold 2.13 RC2)AC68080 @ 78 MHz (x11) on my setup (A2000/Vampire 500 V2+).
 
  Seems to be fine.
 
  Is there an x12 or x13 release of Gold 2.13RC1 for V500?  I didn't see that in the archive.  I would assume it's coming when released. :)
 
  Thanks to the team for all the updates!
 
  Darren
 


Michael AMike

Posts 150
04 Jan 2021 13:10


I am currently testing the CD32 emulation with the OverdriveCD again. Basically it works very well - but unfortunately I have a problem when I want to map the CD32 Kickstart. Contrary to the instructions in the WIKI, the command VControl MAPROM=DH0:Kick32.rom always causes a reboot and the Amiga doesn't load the rest of the startup-sequence.
 
  I have entered the following commands in the start-up sequence:
  c:VControl MAPROM=DH0:Kick32.rom
  c:VControl AKIKO FPU=0 SUPERSCALAR=0 TURTLE=1 VBRMOVE=0
 
  The maprom causes always a reset.
 
  I boot the Amiga from an adapted OverdriveCD bootdisk which works quite well - beside the mentioned maprom problem. Core is V1200RC3 and the latest VControl software. Any ideas? Thanks :)
 
 

posts 125page  1 2 3 4 5 6 7