Overview Features Instructions Performance Forum Downloads Products Reseller Contact

Welcome to the Apollo Forum

This forum is for people interested in the APOLLO CPU.
Please read the forum usage manual.
VISIT APOLLO IRC CHANNEL



All TopicsNewsPerformanceGamesDemosApolloVampireCoffinReleases
Questions and Answers for Coffin AMIGA OS

ATTN CoffinOS Guys, the SMBFS On R51 Is Buggy/oldpage  1 2 3 

Eric Gus

Posts 221
21 Apr 2018 06:39


Just wanted to throw out there that the supplied SMBFS (for SMB/Samba windows shares) is old, its also buggy and will lockup/hang a machine when you attempt to UPLOAD (downloads work fine, its the uploads that fails) .. There is a newer version of SMBFS on Aminet 1.74 which, when you replace the current 1.02 version on R51 fixes all the samba/smb problems.. (this needs to be updated in BOTH c: and samba: as smbmounter-gui has its own copy there as well)
   
Secondly, I would like to recommend the addition of a v2expeth.config file in env:SANA2/ folder, this sana2 config file fixes problems with FTP UPLOADING (ftp downloading works fine, its the uploading that need the config file to fix lockups) etc..
   
    (its contents are the same as the sdnet.config file)
   
    TIMER=7000 SPISPEED=1 MTU=1492 FULLDUPLEX
   
   


Shane Stringer

Posts 11
21 Apr 2018 21:45


Thank you, that worked for me.  I just copied the OS8.1 file Programs:Emulators/Shapeshifter/Hardfiles to a SMB share.  300MB, no problems.


Eric Gus

Posts 221
22 Apr 2018 06:50


Yea I was having all sorts of problems both with FTP UPLOADING and with UPLOADING to an SMB share (downloading for both worked fine) .. over on the Vampire FB group a bunch of us sorta worked out the fixes.. so it was a combination effort of a few people..
   
  edit: the version of SMBFS on R51 is actual 1.102 (I had a typeo) the only place I could find this version was on OS4DEPOT .. seems aminet only has the one I mentioned above (1.74) WHICH WORKS .. the 1.102 version does not.. I would highly recommend the CoffinOS guys switch versions.


Renaud Schweingruber

Posts 163
22 Apr 2018 07:09


1.102 seems newer than 1.74 :

EXTERNAL LINK


Eric Gus

Posts 221
22 Apr 2018 09:04


Renaud Schweingruber wrote:

1.102 seems newer than 1.74 :
 
  EXTERNAL LINK 

Yes but its broken..  it hangs your machine when you attempt to upload something to the SMB server ..

Oddly Aminet only has the working 1.74 version ..

I don't know how extensively they tested the 1.102 version but I suspect no one actually tried to push something UP TO an SMB server with 1.102 .. downloads work fine, but uploading something.. no not so much.. and as I said, this was confirmed by multiple people ..


Mo Retro

Posts 175
22 Apr 2018 10:15


As I said in the fb Vampire group. I don't have any upload problems with smb and I use the version 1.102 that came with R51.
  The only thing that was remarkable was that upload speed was a meager 75kB/s against 549kB/s download speed.
  I'll try to work on that when I got some spare time.


Renaud Schweingruber

Posts 163
22 Apr 2018 10:45


I just succeeded in compiling smbfs 1.116 from latest sources ( EXTERNAL LINK ).
 
Could someone try it ?
 
EXTERNAL LINK


Mo Retro

Posts 175
22 Apr 2018 11:29


Renaud Schweingruber wrote:

I just succeeded in compiling smbfs 1.116 from latest sources ( EXTERNAL LINK ).
   
  Could someone try it ?
   
  EXTERNAL LINK 

Renaud I just made the test and works for me like on the 1.102. No upload problems. Same upload and download speed as above.
This was done on my A600 V2 and a WiFi card


Mo Retro

Posts 175
22 Apr 2018 11:59


I've tested the 1.74 version also this gave me a lower download speed on my WiFi card 240kB/s against 310kB/s with smbfs v1.116.
The upload was the same around 70kB/s.



Shane Stringer

Posts 11
22 Apr 2018 13:02


1.116 gives me the same problem as 1.102


Mo Retro

Posts 175
22 Apr 2018 14:16


I've also done the test on my A500V2+ SDNet now.
  1.116 is slightly faster in download speed then 1.102.
  Upload stays at around 75kB/s.
  1.74 gives me lower transfer speed.
  I think there must be also another factor here for the other users.


Mo Retro

Posts 175
22 Apr 2018 14:24


Shane Stringer wrote:

1.116 gives me the same problem as 1.102

What do you use for connection? SDNet or v2expeth?
Do you have a config file in the ENVARC:sana folder for SDNet and/or V2expeth
Settings in these files should be:
  'TIMER=7000 SPISPEED=1 MTU=1492 FULLDUPLEX'
If it still gives you problems try to set SPIPEED to 2.
Good luck :)
   
   


Mo Retro

Posts 175
22 Apr 2018 14:58


I forgot to mention that smbfs 1.116 worked out a little bit faster in download speed then 1.102 on my 500V2+ @x11
I got 580kB/s in stead of 550kB/s. 1.74 was around 300kB/s.

So in my case I prefer the newest version.


Shane Stringer

Posts 11
22 Apr 2018 15:06


I'm using v2expeth on an A500, core GOLD2.9 (5115, x10 EXE).  I have a config file in ENVARC:Sana2/v2expeth.config with the settings you gave.  I have changed to SPISPEED=2, but it did not help.


Mo Retro

Posts 175
22 Apr 2018 16:06


Shane Stringer wrote:

  I'm using v2expeth on an A500, core GOLD2.9 (5115, x10 EXE).  I have a config file in ENVARC:Sana2/v2expeth.config with the settings you gave.  I have changed to SPISPEED=2, but it did not help.
 

  Where do you change the smbfs file?
  Because its in the C directory and in the SMBMounter directory.
  Change it in both places and redo your testing.
  One could try to remove it from C and watch if it gives an error ;-)


Shane Stringer

Posts 11
22 Apr 2018 16:49


I'm replacing the smbfs file in C: and in Programs:Internet/SMBMounter (assigned to SAMBA:).  Removing it from C: doesn't give an error, so I guess the SMBMounter-MUI program I'm using, uses its own copy in SAMBA:


Renaud Schweingruber

Posts 163
22 Apr 2018 17:17


Nice, I get good results with this 1.116 too while 1.74 gives me recoverable alerts. I'm uploading it to Aminet.


Mo Retro

Posts 175
22 Apr 2018 17:31


Renaud Schweingruber wrote:

  Nice, I get good results with this 1.116 too while 1.74 gives me recoverable alerts. I'm uploading it to Aminet.
 

  Thanks Renaud:-)
What did you change exactly?


Renaud Schweingruber

Posts 163
22 Apr 2018 17:51


I did nothing, I just compiled it from available sources. Seems binaries have never been available until today.

ChangeLog is missing since 1.106 :
EXTERNAL LINK


Mo Retro

Posts 175
22 Apr 2018 18:13


Renaud Schweingruber wrote:

  I did nothing, I just compiled it from available sources. Seems binaries have never been available until today.
 
  ChangeLog is missing since 1.106 :
  EXTERNAL LINK 

  Strange I thought the sources were only on sourceforge:
  EXTERNAL LINK

posts 57page  1 2 3