Overview Features Instructions Performance Forum Downloads Products OrderV4 Reseller Contact

Welcome to the Apollo Forum

This forum is for people interested in the APOLLO CPU.
Please read the forum usage manual.
VISIT APOLLO IRC CHANNEL



All TopicsNewsPerformanceGamesDemosApolloVampireAROSWorkbenchATARIReleases

Where Can I Download Femu?

Bart Mikulski

Posts 100
02 Dec 2018 12:40


The link in this thread:

CLICK HERE 
is dead.

Thanks!


Vojin Vidanovic

Posts 1590
02 Dec 2018 14:32


FEMU is no longer needed with core 2.11. We have a hardware FPU. It was software emulator way back.

Its included in SAGA drivers or core archive when applicable.


Bart Mikulski

Posts 100
02 Dec 2018 18:04


Yes, I'm aware of it. I'd like to try it in Gold 3 alpha - this core does not have any FPU.


Haydar YÜKSEL

Posts 13
02 Dec 2018 20:37


There is in the gold 3 alha archive (femu.040)


Bart Mikulski

Posts 100
02 Dec 2018 20:39


Haydar YÜKSEL wrote:

There is in the gold 3 alha archive (femu.040)

I know, but I've read that .080 is necessary for the Vampire. Does .040 work?


Renaud Schweingruber
(Apollo Team Member)
Posts 311
02 Dec 2018 21:30


We have put best version in GOLD3 Alpha package. Just use that one if required.


Bart Mikulski

Posts 100
02 Dec 2018 21:34


Ok, I will try it. Thanks!


Vojin Vidanovic

Posts 1590
03 Dec 2018 10:40


Bart Mikulski wrote:

  I know, but I've read that .080 is necessary for the Vampire. Does .040 work?

No, all 040 code works fine ;-)
080 AMMX versions are most welcome, but since only VASM supports it, you cant expect it always. As well as this version of Femu should work on 040EC/LC too.

However, FEMu emulated FPU isnt neither fast or precise as 2.11+ implemented one, even less V4 expected implementation. Take it as FPU software enabler and temporary fun.


posts 8