Overview Features Coding Performance Forum Downloads Products OrderV4 Contact

Welcome to the Apollo Forum

This forum is for people interested in the APOLLO CPU.
Please read the forum usage manual.



All TopicsNewsPerformanceGamesDemosApolloVampireAROSWorkbenchATARIReleases
Documentation about the Vampire hardware

V4BL,balenaEtcher and Windows 10 Problems.

Dj Up

Posts 37
29 Mar 2021 20:35


Good evening all.
So I finally got my new CF-card reader (Sandberg) and I thought my waiting was over. Well I had to go through the Turbo install again and this time with a 64 GB.. because the common reasons.. And did that for around an hour.. Now finally its time, fire up windows 10 (thought it would be worth it for a short period of time,to get this done).

Well good news is Windows see the card-reader and its card,and the bad news is balenaEtcher just came back with error and would not write to it..And in addition to that windows 10 wanting me to format the drive,which I did not see as a step in walkthrough guide (as it said everything would be 100% overwritten with balenaEtcher) ,so I did not want windows 10 to do anything,and it can only do exfat anyway or something,not the original fat(32). 

After I rejected the format windows then say it does not recognize the thing and it just vanish from the system.

Of course there are ways to format it in correct fat-system,but not sure that would solve balenaEtcher`s problem though since it was suppose to overwrite it all and just did`nt want to..

So then I got stuck there. I got very little experience with balenaEtcher and even CF-cards in general, so any suggestions from this community would be nice.


Bartek Kuchta

Posts 44
29 Mar 2021 22:18


I'm using Win32 Disk Imager without any issues whatsoever.

EXTERNAL LINK 
As for Windows, as usual it is a good practice to reinstall USB drivers if anything else fails. Or switch to V4+ for good:)


Dj Up

Posts 37
29 Mar 2021 22:44


Bartek Kuchta wrote:

I'm using Win32 Disk Imager without any issues whatsoever.
 
  EXTERNAL LINK 
  As for Windows, as usual it is a good practice to reinstall USB drivers if anything else fails. Or switch to V4+ for good:)

Thanks for the suggestion Bartek. I had a try with it and it ended with the same error. I really dont want to format it as atm. it at least should have a working Apollo OS on it,but I guess I`m out of options if I want to try anything else I`d have to risk-it or something at some point. I guess before taking to big risk I could shut windows 10 down,and boot up OSX,but my experience with OSX is about the same level as with Amiga and its "OS`es" .




Dj Up

Posts 37
30 Mar 2021 01:11


Well I guess I might as well just try formating the CF-card as when put back into Vampire I was greeted with a message about put boot-drive in thing.. So nothing really happened when trying to do things in windows 10,but it still got corrupted somehow.. Hopefully not dead..


Dj Up

Posts 37
30 Mar 2021 02:14


I have no idea where this issue come from,but no tools in windows worked for a format and I had a go at it in gparted within linux which at least gave me a clue to the fact partition-table was needed. However it did not like "msdos"-type partition-table and now I am just amazed how fragile this sorta drive is. At least gparted could see the drive..


Dj Up

Posts 37
30 Mar 2021 05:09


Success!
To sum up the solution to all this, and I`m not sure how it actually worked but will do my best assumptions to what did go wrong first.

I think that for some reason the CF-card got into problems because of a failed unmount or something, which then again led to the windows 10/balenaEtcher issues. Not sure why windows 10 did not let me format it in any way though,because in the end after trying lot of things with all kinds of different approaches I find myself in windows again and tried just a regular format,actually just to make the drive somewhat mountable again I did the exfat because I thought I`d just go and fix it to fat32 later if it worked.. Well,it worked.. So before changing that to fat32 I had another attempt with the Etcher.. It was writing and validating just fine..

At this point I was curious to see if it would boot in the V4,so I prepared the SD-card and had a go at it. I was shocked,but it booted. I actually had Coffin OS starting installing on the Vampire. Even Aros Vision worked,and it was a first time test for me.

The cf-writer might have had some glitches in beginning,and of course maybe added on with user-errors by me. It is more likely it is the writer and not the CF-card that is fragile.. Even though it does not make sense that the CF-card that had no writing to it would get into that much trouble because of a half-way bad unmount or something. The bootloader itself must be a mind-reader anyway,since I was sure I made tons of errors installing within FS-UAE,but it still worked.

Not sure I`d be telling anyone to buy that sorta card-reader/writer though.

posts 6