Overview Features Instructions Performance Forum Downloads Products OrderV4 Reseller Contact

Welcome to the Apollo Forum

This forum is for people interested in the APOLLO CPU.
Please read the forum usage manual.



All TopicsNewsPerformanceGamesDemosApolloVampireAROSWorkbenchATARIReleases
Documentation about the Vampire hardware

V1200 Dont Boot With Micronik Z2

Cyberstormer Amiga

Posts 7
10 Sep 2020 11:06


Got a Micronik Z2 from ebay,
unfortunately my Vampire V2 does not boot with the Micronik plugged in.
does someone have an idea ?


James Husted

Posts 13
10 Sep 2020 17:16


if I had to hazard a guess its to do with DMA? Im no expert but some cards that need DMA wont work along side a V500 in an Amiga 2000 - probably the same thing going on here?



Igor Majstorovic
(Apollo Team Member)
Posts 351
10 Sep 2020 19:51


I m guessing that same problem we have with mediator. When we fix mediator problem Micronik should work too. This should be relatively easy fix. In some topic I have explained what is the problem. But, with next sentence I will write I m hoping that I won't start another discussion. With Vampire 1200 I hardly need something else to plugin beside card itself. However, system with mediator starts but PCI cards refuse to work. I m not familiar with how Micronik Z2 work regarding internal logic. Maybe someone can provide more info to me?


Cyberstormer Amiga

Posts 7
17 Sep 2020 15:18


If you wish, I can send you the Micronik, if it helps,
I will take care of shipping costs for there and back.

posts 4