Overview Features Instructions Performance Forum Downloads Products OrderV4 Reseller Contact

Welcome to the Apollo Forum

This forum is for people interested in the APOLLO CPU.
Please read the forum usage manual.
VISIT APOLLO IRC CHANNEL



All TopicsNewsPerformanceGamesDemosApolloVampireAROSWorkbenchATARIReleases
Documentation about the Vampire hardware

V1200 / Issue With Vampireflash314

Cyril G

Posts 12
16 Mar 2020 23:19


Hello,

I try to flash a modified Kick3.1.4 (only modification is IntuitionV45) as describe on the Wiki, but I get an error "Cannot identify Vampire V2 Flash chip".
Any idea to solve that ?
Thanks a lot


Juan Jose

Posts 17
17 Mar 2020 09:14


The same here.
But to do this I use "VControl MR" in the first line of the "Startup-Sequence".


Juan Jose

Posts 17
17 Mar 2020 11:05



More information here:

https://wiki.apollo-accelerators.com/doku.php/system_tools:kickstarts


Juan Jose

Posts 17
17 Mar 2020 11:41



I have it like this:

EXTERNAL LINK


Renaud Schweingruber
(Apollo Team Member)
Posts 323
17 Mar 2020 16:48


New version supporting V1200 will come soon


Cyril G

Posts 12
18 Mar 2020 00:30


Juan Jose wrote:

The same here.
  But to do this I use "VControl MR" in the first line of the "Startup-Sequence".

Thanks Juan for this method, I already use a similar one with VampireMap314.
I want to move forward by integrating the new Kickstart directly into the Core and to avoid the maprom reboot ; apparently the Vampireflash314 is not yet compatible with the V1200



Cyril G

Posts 12
18 Mar 2020 00:30


Thanks Renaud, I hope the update will come soon, I have time to spend at home these days :-D


Dma Con

Posts 13
18 Mar 2020 08:46


The last pre-final FPGA Core archive from Simo contains a compatible VampireFlash tool for the V1200. I was able to flash my Kick 3.1 ROM using it.

EXTERNAL LINK


Cyril G

Posts 12
18 Mar 2020 10:16


DMA CON wrote:

The last pre-final FPGA Core archive from Simo contains a compatible VampireFlash tool for the V1200. I was able to flash my Kick 3.1 ROM using it.
 
  EXTERNAL LINK 

Excellent! thank for the link, I will try that today


Renaud Schweingruber
(Apollo Team Member)
Posts 323
18 Mar 2020 11:37


Updated with last version in Wiki

https://wiki.apollo-accelerators.com/doku.php/system_tools:kickstarts#installing_kickstarts


Sean Sk

Posts 347
18 Mar 2020 12:26


Renaud Schweingruber wrote:

Updated with last version in Wiki
 
https://wiki.apollo-accelerators.com/doku.php/system_tools:kickstarts#installing_kickstarts

WOW you guys were onto it super quick, that's awesome! Thanks Renaud.



Renaud Schweingruber
(Apollo Team Member)
Posts 323
18 Mar 2020 20:26


All kudos to Henryk Richter ;-)


Henryk Richter
(Apollo Team Member)
Posts 117
19 Mar 2020 10:21


Word of advice on VControl: VControl will only map the regular unexpanded Kickstart (unless you have custom 1 MB ROMs). This means that you will not get the Vampire support modules in extended ROM space when mapping regular 512k Kickstarts that way.

While the stock A1200 ROM will automatically detect the V2/V1200 FastMEM, everything else related to the Vampire features will be unavailable with 512k ROMs. The most notably lost feature is AMMX, for starters.

I would suggest to use VampireMap314 instead. Despite it's name, it was supports and was tested with a lot of Kickstarts from 1.3 upwards, including betas of 3.2.


Cyril G

Posts 12
19 Mar 2020 16:38


Thanks guys for updating this thread.

I tried the new Vampireflash314 with the default installed core shipped on the V1200 and it worked perfectly this time (remember, it was a custom Kickstart314 with embedded Intuition.library V45).

Then I decided to update the board with the latest core revision (flashrom version for PCMCIA/Modo IDE) and the update went very well (and I noticed speed improvement under Syspeed and a better compatibility with Battle Squadron WHLoad, yeah!!!).
Finally, I flashed again the custom Kickstart to the new core with Vampireflash314 and it works perfectly again.

Now I have a strong foundation to push my setup further, happy ;-)
Regarding VControl, I used it only for IDESPEED and MOVEVBR, but deactivating it since I updated the latest core without the IDE Vampire.

Now, I have a remaining bug with my setup, the WB is stuck to 256 colors, but I will open another thread for that.

Thanks again


posts 14