Overview Features Instructions Performance Forum Downloads Products Reseller Contact

Welcome to the Apollo Forum

This forum is for people interested in the APOLLO CPU.
Please read the forum usage manual.
VISIT APOLLO IRC CHANNEL



All TopicsNewsPerformanceGamesDemosApolloVampireCoffinReleases
Documentation about the Vampire hardware

Vampire V500 V2+ Version 2.1 Power and Video Fixespage  1 2 

Pedro Manuel Lopes Torre

Posts 11
17 Nov 2018 01:06


Hi, my card is a V2.1 Vampire V500 V2+ .

Does it need the Power and Video Fixes to work with latest Cores (2.11 )?

Can someone point me to right direction? The Vampire hangs with Core 2.10/2.11 installed.

I've a friend with good soldering skills who can fix the card for me but i need precise information to do that.

Can Majsta shed some light in this matter?

I've already posted in another thread but no answes.

Best regards,
Pedro Torres


Pedro Cotter

Posts 100
17 Nov 2018 07:56


Hi.

Usually the Vampire V500 V2+ do not need the Power mods.
I suggest that you try to reach Majsta on the IRC or take Hi-Res pics from both sides of the board and send them to him.

regards,


Andrew Miller

Posts 150
17 Nov 2018 09:57


Is your Amiga recapped? The power fix is for older V600's not the V500's. Have you tried another PSU?


Igor Majstorovic
(Apollo Team Member)
Posts 251
17 Nov 2018 12:39


I have published article about that matter on my website  EXTERNAL LINK so best option is to compare pictures with your card.


Pedro Manuel Lopes Torre

Posts 11
17 Nov 2018 22:54


Hi, both motherboard and PSU were recapped 1 month ago.

Hi Igor,I've seen your photos and appears that my card has those fixes already so probably it's a core issue.

I've tested the actual core that is available 2.11 x11 and the cards hangs, so if there's a fix i would like to know.


Andrew Miller

Posts 150
17 Nov 2018 23:40


I see in another post that you have tried it in another A500 rev 6 and same issue. Though that should mean it doesnt need any power fix, as far as I know that was only for the V600 version.
  Do you have any other hardware connected to the card?
  Otherwise Majesta is probably your best bet at getting a solution.

Other thing I would suspect is if it has had those fixes and didnt need them, then that could in fact be the issue.


Pedro Manuel Lopes Torre

Posts 11
18 Nov 2018 09:04


Hi, the tests were made with only the Vampire.

Later, i tested with the Buddha 20th Year Edition and At-Bus 2008 Clone, but the results were the same.

I've used a 80GB and a 160GB sata with adapter to IDE, hangs
Used an 40GB IDE with Coffin, still hangs
In a few days, i'll test it with a 32GB CF card to see how it behaves.

My Working config :

Amiga 2000 Rev 6.2 ECS , recapped motherboard and recapped PSU


Igor Majstorovic
(Apollo Team Member)
Posts 251
18 Nov 2018 10:55


Can you please send me a mail or visit us on IRC. It is very hard for me to help over the forum. It is just too slow.


Pedro Manuel Lopes Torre

Posts 11
18 Nov 2018 20:58


Hi Igor, i could send you an email if i knew how through this site.

You can send me an email to pedromanuel.lopestorres@gmail.com and i'll gladly reply.

I've tried Team Apollo's IRC but to no avail.


Pedro Manuel Lopes Torre

Posts 11
21 Nov 2018 00:51


A big thanks to Majsta, my card is running now with Core 2.11

Power fix was made, now running without a problem


Chris T.

Posts 69
02 Dec 2018 12:26


Can you tell us what Majsta did with your Card? I have the same Problems. Thank you in Advance. Chris


Vojin Vidanovic

Posts 732
02 Dec 2018 14:35


Chris T. wrote:

  Can you tell us what Majsta did with your Card? I have the same Problems. Thank you in Advance. Chris
 

 
  Nothing was done to a Vamp card. Power fix relates to A500 board/PSU brick capacitors.
 
  e.g. fixing power capacitors on A500
  EXTERNAL LINK


Marlon Beijer

Posts 124
03 Dec 2018 11:24


Vojin Vidanovic wrote:

 
Chris T. wrote:

    Can you tell us what Majsta did with your Card? I have the same Problems. Thank you in Advance. Chris
   

   
    Nothing was done to a Vamp card. Power fix relates to A500 board/PSU brick capacitors.
   
    e.g. fixing power capacitors on A500
    EXTERNAL LINK 

  Please, there is a version of the V500 V2+ that needs the power fix. Please read the thread fully before you state something as fact. An early revision of V500 V2+ requires the same capacitor fix as the V600 V2. I had to do this on mine.

EXTERNAL LINK


Vojin Vidanovic

Posts 732
03 Dec 2018 11:55


Marlon Beijer wrote:

    Please, there is a version of the V500 V2+ that needs the power fix. Please read the thread fully before you state something as fact. An early revision of V500 V2+ requires the same capacitor fix as the V600 V2. I had to do this on mine.
 
  EXTERNAL LINK 

 
  My bad. Yes, Majsta acknowledges early Vamps done by him need those fixes. Wait for answer by some more knowledgable user. As far as I remember, Majsta had nothing with V500+ production, so its a question are early V600 and your case related.


Igor Majstorovic
(Apollo Team Member)
Posts 251
03 Dec 2018 12:27


@Marlon Beijer please compare your card with those on my site, look at the pictures and description in detail. It is true that there were some V2+ cards who needed power fix but their number is very low, probably only few.


Marlon Beijer

Posts 124
03 Dec 2018 13:11


igor majstorovic wrote:

@Marlon Beijer please compare your card with those on my site, look at the pictures and description in detail. It is true that there were some V2+ cards who needed power fix but their number is very low, probably only few.

We have already confirmed that my card needed the fix on IRC. :)

Here's a link containing images of a V500 rev2 card requiring the fix:
EXTERNAL LINK 
Compare my card to the images on Majsta's website, that I linked above.

As you can see on the pictures, besides the card needing the power fix, it also has resistors instead of capacitors for the DIGITAL VIDEO port.
This is very hard to fix if you don't have the knowledge and the right tools, as you could damage the card and other components with heat.

So I decided to only do the power fix, as I've had no issues with DIGITAL VIDEO on the monitors I've tested it on. Only a repeater was required.


Marlon Beijer

Posts 124
03 Dec 2018 13:13


Vojin Vidanovic wrote:

Marlon Beijer wrote:

    Please, there is a version of the V500 V2+ that needs the power fix. Please read the thread fully before you state something as fact. An early revision of V500 V2+ requires the same capacitor fix as the V600 V2. I had to do this on mine.
   
    EXTERNAL LINK   

  My bad. Yes, Majsta acknowledges early Vamps done by him need those fixes. Wait for answer by some more knowledgable user. As far as I remember, Majsta had nothing with V500+ production, so its a question are early V600 and your case related.

  Majsta always did the V500+, while Kipper used to do V600. I received my card directly from Majsta. I don't speak out of my ***, as I have already confirmed that this is the case.


Chris T.

Posts 69
03 Dec 2018 21:06


Dear Marlon, thank you for your info. I have the same Card as you and got it directly from Majsta two years ago :-). Dear Majsta, can you check my Card? I have also the SNR...


Igor Majstorovic
(Apollo Team Member)
Posts 251
03 Dec 2018 21:16


@Chris T. if you could contact me on mail or IRC pls if you have some problems with the card. If your card runs latest cores without problems then you don't need to check anything. If you have some problems like I suggest go to my website and compare pictures from latest article.


Chris T.

Posts 69
03 Dec 2018 21:33


I JUST SEND YOU AN EMAIL TO yahoo account

posts 23page  1 2