Overview Features Instructions Performance Forum Downloads Products Reseller Contact

Welcome to the Apollo Forum

This forum is for people interested in the APOLLO CPU.
Please read the forum usage manual.
VISIT APOLLO IRC CHANNEL



All TopicsNewsPerformanceGamesApolloVampireReleases
Documentation about the Vampire hardware

Vampire V4 Backwards Compatibilitypage  1 2 

Emufr3ak -

Posts 6
14 Nov 2017 22:06


I'm looking for a Device that will run all Amigasoftware.

Will it be possible to use OCS-Chipset and 68000 also in the Vampire V4 Standalone?


Vojin Vidanovic

Posts 655
14 Nov 2017 22:38


No, its not possible. But much of the software will work on Vamps as its quite backward compatibile, including most of 68k and OCS software.


John William

Posts 218
14 Nov 2017 22:59


Emufr3ak - wrote:

I'm looking for a Device that will run all Amigasoftware.
 
  Will it be possible to use OCS-Chipset and 68000 also in the Vampire V4 Standalone?

Dude the point of v4 is to be accelerator which means you hook it into the Amiga classic and use the custom chipset there but add into it in additional improving in the custom chipset OR as stand alone which have build in custom chipset with modern new chipset and hardware.

It would be pointless to have chip sockets to move old hardware chipset into it.

Don't you agree? Heck even in fpga arcade and minimig don't do this.

There is one new hardware for a500 where it adds new ports and stuff, make it slimmer and use those chipsets you seek but that is just a normal a500 with little tweaks and modification and it will not even fit in a real a500 case either. No thanks for that hardware.


Ian Parsons

Posts 125
14 Nov 2017 23:44


A device to run "all" Amiga Software would need to be VERY re-configurable. Emulation (UAE) is probably the only solution with enough options, although it can't currently run 68080 software.

The V4 standalone is not a 68000 based OCS device, it's 68080 with SAGA. Badly written software that doesn't work on anything but OCS 68000 will need fixing e.g. with WHDLoad to run on the V4 just as it would to run on any other Amiga that isn't a stock A500.


Mallagan Bellator

Posts 135
15 Nov 2017 00:01


John William wrote:

Emufr3ak - wrote:

  I'm looking for a Device that will run all Amigasoftware.
 
  Will it be possible to use OCS-Chipset and 68000 also in the Vampire V4 Standalone?
 

 
  Dude the point of v4 is to be accelerator which means you hook it into the Amiga classic and use the custom chipset there

He is talking about the standalone. You donít connect that one to an actual Amiga.
Besides, the AGA chipset will be implemented into the core, and even enhanced, as in better than AGA, even with better Paula



Thierry Atheist

Posts 575
15 Nov 2017 00:35


I was always under the assumption that there simply won't be ANY OTHER DEVICE than the standalone that will be more backwards compatible with all AMIGAs that there were, EXCEPT FOR particular ports, and the fact that it lacks expansion slots, for instance, you can't attach the NewTek Video Toaster.

One more thing, the MMU is "no go", not gonna happen. There was more than one MMU anyway, so it would have been tricky, if even possible,  to implement. Not particularly worrisome for most users, I don't care if it's ever available.

OCS/ECS/AGA will have 2 modes, I imagine; a "compatibility mode" (which will run at ~7.12 MHz, or whatever was the original speed) and an "unlimited mode" that runs as fast as the FPGA can operate.

It's gonna be AWEEEE-SOME!!!!!!!!


Markus Horbach

Posts 30
15 Nov 2017 04:17


Emufr3ak - wrote:
>I'm looking for a Device that will run all Amigasoftware.

all Amiga Software written for
Amiga 500
Amiga 500 plus
Amiga 600
Amiga 1000
Amiga 2000
Amiga 3000
Amiga 4000
CD32
PAL/NTSC models
all in delivery condition ?
or supporting also expanded machines with added
-fastmem
-faster CPU (depends on model 68k0x0 to start from)
-added RTG grafics
-PPC support ?
What about software requiring special hardware, eg. Zorro expansion cards
-CDROM
-hard disk ??? most amigas in delivery condition had no HDD, especially the most popular, Amiga 500 had no HDD. So we need a SCSI Docking station with the Apollo Vampire, too ?
All above listed Amigas were never compatible to each other, and all expansions and accellerator cards made the gap between all models bigger.

Are software patches for the Amiga OS (Kick or WB) allowed to make it compatible or will this hurt compatibility to all software written ?

The Apollo Vampire (no matter which model) did the miracle to make all A500/600 models more compatible to the big box amigas. Running software like OS 3.9 which was never intended to run on an Amiga500/600 in delivery condition.

An Vampire V4 Amiga running all software ever written for an Amiga will break compatibility for all Amigas, because a guru meditation never seen while using an Amiga is not the real experience !

A scattered hardware platform is part of the Amiga experience and this is an disadvantage of Amiga in general. Live with it.


Emufr3ak -

Posts 6
15 Nov 2017 05:40


I guess I was not specific enough. I'm mainly interested in Demos for Classic Amiga. From Highend TBL stuff till OCS stuff like State of the Art. At the Moment I'm using the MIST board which works great for most of the stuff. It's too slow for most Highend stuff. You can switch the core between AGA and OCS and adjust the CPU and Kickstart. Up till now I only found one OCS Demo that didn't work. Mist is using the Opensource Minimig core. It would definitely be possible to port this to the Vampire for someone with more skills.


Gunnar von Boehn
(Apollo Team Member)
Posts 2957
15 Nov 2017 08:19


Emufr3ak - wrote:

From Highend TBL stuff till OCS stuff like State of the Art.

Yes this works of course.


Vojin Vidanovic

Posts 655
15 Nov 2017 10:50


Emufr3ak - wrote:

Opensource Minimig core. It would definitely be possible to port this to the Vampire for someone with more skills.

Shortest answer is: Apollo is far more compatibile and superior to MIST, Minimig and FPGA Arcade, as well as faster. There is no need to go back. You will enjoy Vamp exp to MIST one.


Emufr3ak -

Posts 6
15 Nov 2017 11:47


How is this achieved? On Mist I get faulty output on State of the Art for example if AGA is switched on.
 
  As I understand it, Vampire V4 (Standalone) will only support AGA. This means Demos that are designed for OCS Only will fail, like on a a real Amiga 1200. Am I wrong? Or do I need Whdload or other tricks to get them running?


Gunnar von Boehn
(Apollo Team Member)
Posts 2957
15 Nov 2017 12:08


Emufr3ak - wrote:

On Mist I get faulty output on State of the Art for example if AGA is switched on.

   
APOLLO/VAMP and MIST or ARCADE have nothing to do which each other.
   
  - The VAMP is not only about 20 times faster than ARCADE/MIST
  - The 68080 CPU is also much more compatible
  - The SAGA chipset support more features.
   
  - The VAMP can run MAC-OS - while ARCADE/MIST crash because they are not compatible
  - The VAMP with GOLD 3.0 runs also some AGA games - which crash on ARCADE/MIST
  - The VAMP supports many more GFX modes and is also designed to display both PLANAR and CHUNKY at parallel.
   
   
One thing has to be understood.
Old software was not written to run only on OCS on purpose, but some software was just written badly.
For example old software could have included programming errors which might crash it on faster CPUs.
Or some program might crash with fastmem or when the chipset is faster.

These programming errors would go unnoticed on the A500 - but show up on faster systems or systems with caches
   
It is not possible to give a 100% guarantee that ALL of the old programs that did contain programming bugs will work like on an A500!
   
APOLLO and SAGA include some special features which help run these buggy programs nonetheless.
These features work very good and fix many buggy programs.
Some of these "tricks" need full control of both CPU and Chipset, this means they will work better with GOLD 3.0 than with GOLD 2.0.
It goes without saying, while the goal is that 100% works - we can give no guarantee.


Vojin Vidanovic

Posts 655
15 Nov 2017 12:12


Emufr3ak - wrote:

  As I understand it, Vampire V4 (Standalone) will only support AGA. This means Demos that are designed for OCS Only will fail, like on a a real Amiga 1200. Am I wrong? Or do I need Whdload or other tricks to get them running?

As with A1200 AGA is quite ECS/OCS compatibile. Since 080 is "040+ class CPU" yes, use of WHDLoad helps.


Account for Sale

Posts 196
16 Nov 2017 14:42


Gunnar von Boehn wrote:

  - The VAMP can run MAC-OS - while ARCADE/MIST crash because they are not compatible

Just to nitpick a little, there are dedicated softcores to run MacOS on MiST (and MiSTer), so that has been possible for years already. And Jim Drew has demonstrated MacOS on the FPGA Arcade many times.


Gunnar von Boehn
(Apollo Team Member)
Posts 2957
16 Nov 2017 17:13


Account for sale wrote:

Jim Drew has

 
Jim has stated many times the ARCADE CPU is not compatible enough.


Emufr3ak -

Posts 6
16 Nov 2017 19:21


I guess a Vampire 4 for an Amiga 500 might be a good option too. I could disable the Vampire in case of any problems running some old demos.


Gunnar von Boehn
(Apollo Team Member)
Posts 2957
16 Nov 2017 19:56


Emufr3ak - wrote:

  I guess a Vampire 4 for an Amiga 500 might be a good option too. I could disable the Vampire in case of any problems running some old demos.
 

 
On AMIGA most software can run fine on both on slow 68000 as faster CPUs.
So the speed of the CPU is very rarely a problem.
 
Sometimes AMIGA programs used selfmodifying code.
These programs used to crash on CPU with caches.
Especially on the 68040 and 68060 which had big caches selfmodifying code failed.
 
68080 is more compatible than 68040 and 68060, as it has "smart" caches which support selfmodifying code.
 
I would recommend the Vampire to people which want to upgrade to run software they could never run before.
MP3 player, Video player, modern Webbrowser, Games which required 68040 or 68060 CPUs.
 
Like with any faster AMIGA (e.g like A4000) there is a chance an old and buggy coded program could run bad.
People should only buy the Vampire or any other accelerator - if they are aware of this and accept this.



Steve Ferrell

Posts 149
16 Nov 2017 21:15


Emufr3ak - wrote:

How is this achieved? On Mist I get faulty output on State of the Art for example if AGA is switched on.
 
  As I understand it, Vampire V4 (Standalone) will only support AGA. This means Demos that are designed for OCS Only will fail, like on a a real Amiga 1200. Am I wrong? Or do I need Whdload or other tricks to get them running?

Your expectations are beyond unrealistic.  There are some games and demos that won't even play on the same OCS Amigas sporting the same hardware with the same specs due to differences in motherboard revisions and other minor variations, so why now do you expect to run every piece of software ever written for every Amiga on a Vampire?  That was an unrealistic expectation back in 1990 and even more unrealistic now.

If your interest is strictly in OCS demos and you want maximum compatibility why not just purchase a bog standard A500 and be happy and move on? The Vampire wasn't designed nor targeted toward the .05% of Amiga users who just want OCS demos. It was designed for and targets the broadest range of Amiga users.  To have designed the Vampire  otherwise would have been just plain stupid.



Emufr3ak -

Posts 6
16 Nov 2017 21:40


I'm well aware that there is no 100% solution. I'm just trying to get closer to it. Mist with it's option to change chipset and cpu comes already closer to this than any Amiga I ever owned came. It doesn't run stuff requiring 68040 and Higher however.
 
  Vampire looks like a possible improvement. I'm also excited about running New Software and Games that were not possible on Amiga before of course.


Vojin Vidanovic

Posts 655
16 Nov 2017 22:08


Markus Horbach wrote:

  >I'm looking for a Device that will run all Amigasoftware.

Any of your devices that can run EXTERNAL LINK  Sorry, but no Amiga or Vamp can guarantee that.

But,  most or most important titles do work on AGA.

posts 26page  1 2