Overview Features Coding Performance Forum Downloads Products OrderV4 Contact

Welcome to the Apollo Forum

This forum is for people interested in the APOLLO CPU.
Please read the forum usage manual.



All TopicsNewsPerformanceGamesDemosApolloVampireAROSWorkbenchATARIReleases
Information about the Apollo CPU and FPU.

Apollo OS R8.2 Not Working On My Amiga 600 Vampire

Alexander Gent

Posts 28
11 Apr 2022 06:35


A quote from EXTERNAL LINK   
ApolloOS runs on all Vampires
    (V500, V600, V1200, V4 and V4+).
    While ApolloOS may run on older 68Ks, the CPU will not have good performance under AROS, nor the speed to play videos with Riva or play demanding games like Diablo. Our focus is to improve the stability of AROS and compatibility with OS 3.x as well as to improve the performance on 68080.
 
  I installed the ApolloOS on my Amiga today.
  I received some interesting errors.
  1) Setpatch Error 20.  I replaced Setpatch with the version from Workbench 3.2. 1st problem solved.
  2) Assign error. Please insert ENV: in any drive. Replaced C:Assign with version from Workbench 3.2. 2nd problem solved.
  3) Mount error. Again replaced from Workbench 3.2. Problem solved.
 
  Finally boot into workbench with stdc.library error. Low Res screen mode which I cannot change. None of the preferences seem to work.
 
  I tried editing the startup-sequence using ED but I received a posixc.library Version 0 not found error.
 
  I have the latest Gold 2.15 firmware installed.
  I tried earlier versions going back to Gold 2.12RC, the same problem each time.
 
  So it seems that ApolloOS R8.2 does NOT work on all Vampires, unless I am missing something.
 
  Any ideas on how to fix these errors?


Gunnar von Boehn
(Apollo Team Member)
Posts 5763
11 Apr 2022 06:56


Alexander Gent wrote:

Any ideas on how to fix these errors?

To run ApolloOS you also need the matching Apollo-Kickstart.
Mixing wrong kickstart with OS will not work.


Alexander Gent

Posts 28
12 Apr 2022 00:12


Gunnar von Boehn wrote:
To run ApolloOS you also need the matching Apollo-Kickstart.
  Mixing wrong kickstart with OS will not work.

  What kickstart do I need to get ApolloOS R8.2 working?
Is there any documentation?

posts 3