Overview Features Instructions Performance Forum Downloads Products OrderV4 Reseller Contact

Welcome to the Apollo Forum

This forum is for people interested in the APOLLO CPU.
Please read the forum usage manual.



All TopicsNewsPerformanceGamesDemosApolloVampireAROSWorkbenchATARIReleases
Information about the Apollo CPU and FPU.

Custom ROM of Min. 1MB for V1200

Day Owalker

Posts 1
03 Jun 2020 17:14


Hi,

I need advice or infos about 1MB custom ROMs and V1200. As soon as I load a corresponding ROM with Vampiremap or VControl, my Amiga seems to lose the V1200 detection and initialization. The card then appears e.g. no longer in the boot menu.
I´ve read something about “Vampire-specific Kickstart modules” in this forum, which tells something like this is needed:
"(From gold 2.8) percent
fpsp080_40.2
processor.resource_44.3
ROMHeader_E0
vampire.resource_45.3
VampireBoot_1.7 (Apollo_G28)
VampireSupport_40.14
workbench.library_40.5A “
(from http://www.apollo-core.com/knowledge.php?b=1&note=17502).

Could it be that with the remap of 1MB ROMs exactly the above mentioned modules are getting lost and therefore are missing?
It would be nice to know if so, and which modules the V1200 needs, and yes, where to find them. I use the last official core.
Thanks.


Manfred Bergmann

Posts 182
04 Jun 2020 10:37



which tells something like this is needed:

The vampire* entries in there are not needed.

What means custom. What did you change? Which OS version do you run?


The Dayowalker

Posts 2
06 Jun 2020 12:34


As I created a new 1MB ROM, naturally there is an 512kb extended ROM in addition to the normal 512kb ROM. The Standard ROM only contains OS 3.1.4 modules, as they are in the original image, on top the 1MB_ROM module, to link the extended ROM. If I use the standard ROM alone, everything is fine. If I use it together with the extended ROM, and it doesn’t matter what it includes, the system loses the correct vampire detection, as it is meant to be( See description above). This is even the case, when the extended ROM is empty, except the corresponding ROM_Header. And it doesn’t matter, wether I use it with VampireMap, splitted up in standard and extended ROM, or VControl, with a merged one 1MB image.

AFAIK in 1MB ROM images, I need to put those Vampire specific ROM modules myself. Where can I get them?

@mods:
I have problems to set up my subscription to the forum correctly. So day Owalker from 1. Post and dayowalker here are the same person, it’s me. I do not receive the confirmation mails on both registerings. Would like to keep this one, if possible. Sorry for the hustle, but I wanted the dialogue here to go on..


Henryk Richter
(Apollo Team Member)
Posts 119
06 Jun 2020 19:01


Manfred Bergmann wrote:

  The vampire* entries in there are not needed.
  What means custom. What did you change? Which OS version do you run?

If you don't want to have AMMX available in AmigaOS, don't have any use for peripherals on the expansion connector(s) and won't care for having FastMem with A500/600 ROM images alongside additional housekeeping, then the vampire* modules are not needed.


The Dayowalker

Posts 2
06 Jun 2020 20:15


Hm, of course I would like to use the peripherals and ads of the Vampire. That’s why I ask for source of the implicated modules.

Isn’t there a possibility for users to use their own 1MB or greater ROM?



posts 5