Overview Features Instructions Performance Forum Downloads Products Reseller Contact

Welcome to the Apollo Forum

This forum is for people interested in the APOLLO CPU.
Please read the forum usage manual.
VISIT APOLLO IRC CHANNEL



All TopicsNewsPerformanceGamesApolloVampireReleases
Running Games and Apps.

Apollo and Amiga OS 3.9page  1 2 3 

John William

Posts 217
08 Mar 2016 21:57


Mr-Z EdgeOfPanic wrote:

Sweet that Dropbox and Google drive work.
  Where did you get that theme for your workbench ?
  I really like the icons and the transparent Amidock :)
   
  Back in the day i did my eyecandy with birdie,visualprefs,magic menu PPC, reqattack etc etc.
   
  Screendump (SGRAB) from Blizzppc+bvision 12 years ago!
   
  EXTERNAL LINK   
   

How do I get a theme like yours? :)



Mr-Z EdgeOfPanic

Posts 143
09 Mar 2016 03:13


@John William

Haha it was i custom theme i made back then, and a lot of work.
Making all these hacks and patches work together was quite a challenge and required some fiddling around in the start up sequence :-)
I still have copy/backup in LHA of that install.


Manuel Jesus

Posts 90
07 Jun 2016 18:43


So when Installing WB 3.9 is it ok to do all the boing bag updates?
 
  What is the optimal install configuration using the Amiga Os 3.9 CD?
 
  I find using AmigaSYS, or Advanced Amiga installs quite buggy on the vampire.

I think it would be a good idea to develop a optimized WB installer. I know this is not a priority for the Vampire team but perhaps of the the 400 or so vampire owners so far can take up the task.


Daniel Sevo

Posts 166
07 Jun 2016 23:44


Manuel Jesus wrote:

So when Installing WB 3.9 is it ok to do all the boing bag updates?
 
  What is the optimal install configuration using the Amiga Os 3.9 CD?
 
  I find using AmigaSYS, or Advanced Amiga installs quite buggy on the vampire.
 
  I think it would be a good idea to develop a optimized WB installer. I know this is not a priority for the Vampire team but perhaps of the the 400 or so vampire owners so far can take up the task.

This is a good question, (I asked it before in EAB :-). What is currently the optimal WB 3.x installation for use with Vampire?
3.1? 3.5? 3.9? 3.9+BB1,BB2,(BB3,BB4)
Any particular things to avoid? Any essential libs etc to add?

This is something for the wiki at EXTERNAL LINK


Manuel Jesus

Posts 90
11 Jun 2016 02:16


Hello,
I have researched this.
I have consistently done AmigaOs installs on Kingston and Transcend Flash cards approved on EAB.

Install Os 3.1, then Install 3.9, boing bags 1 and 2 (without the rom update) then google search boing bags 3 and 4 and install those.

I have also tested AmiKIT real. A bit too much bling bling but it works at great speed.



Amiga 4Life

Posts 54
18 Jun 2016 03:36


AmigaOs 3.9 always looked good its just that now Apollo/Vampire makes it more usable, especially with A600 hardware.. no more reducing screen resolutions and turning down color depth in order to gain performance... Vampire can handle the bandwidth and a little bloat...:)
     


Simo Koivukoski
(Apollo Team Member)
Posts 263
24 Jan 2017 07:26


If you like to use Kick 3.9 (AmigaOS ROM Update BB39-2) with GOLD2 core, you need to patch your DEVS:AmigaOS ROM Update -file and modify SetPatch command line in your Startup-Sequence. Download your SAGA2 update package and spatch.68k:
                 
EXTERNAL LINK                   
EXTERNAL LINK                     
               
Copy ARU_Vampire_1_2.pch to SYS: (it's in GOLD2\Extras -folder) and spatch.68k file to C:. Before you reboot your BoingBag39-2 installation run spatch.68k:
C:spatch.68k -o="DEVS:AmigaOS ROM Update" -p=SYS:ARU_Vampire_1_2.pch "DEVS:AmigaOS ROM Update.BB39-2"
Then modify Startup-Sequence:
SetPatch SKIPROMUPDATES scsi.device
Now you are ready to reboot for your BoingBag39-2 installation with the AmigaOS ROM Updates (Kick 3.9).
                   
You can check that the installation was successful with the WhichAmiga:
             

                   
GOLD2 has modified PCR register and 68080 now acts as a 060. You can check this also with the SysInfo:
             

       
Vampire has build in 68080.library, so no need for 68060.library in LIBS:.


Neil 8bitplus

Posts 9
24 Jan 2017 15:02


I patched the bb2 rom for the Gold1 core. Does this need doing again for the Gold2 core?


Simo Koivukoski
(Apollo Team Member)
Posts 263
24 Jan 2017 15:12


Patch is upgraded to support of 68060 identification. You should still have the original AmigaOS ROM Update.BB39-2 file in DEVS:, so updating is easy to do.


Leigh Russ

Posts 11
29 Jan 2017 23:52


I only got my Vampire a couple of weeks ago. Running OS3.9 BB2 and it works great on Gold1 core with the 1.1 patch for the ROM update.

The issue I have is that when using Gold2 I am only able to boot using NOROMUPDATE and if I have removed my physical kickstart ROM. When using the supplied 1.2 patch I just get a black screen when using SKIPROMUPDATES SCSI.device.... Any ideas on what could be causing it?

I also find that if not using the BB2 ROM update when on GOLD2 it often doesn't boot from CF card at all unless I power I off at the wall for a few seconds. And when it does boot up it often stops my Rys MKII mouse adapter working.

Getting a bit frustrated with it now do gone back to Gold1 as this boots every time, even with my physical ROM fitted.

Any ideas or anyone else had an issue?


Chris Holzapfel

Posts 29
30 Jan 2017 00:08


I had the same issue, but did not have the time yet to sort it out. So I flashed back to Gold1 for now as well.


Simo Koivukoski
(Apollo Team Member)
Posts 263
30 Jan 2017 13:45


Simplified troubleshooting chart would be:
     
  1. start your Amiga from the early-startup without startup-sequence
  2. type "SetPatch SKIPROMUPDATES scsi.device QUIET"
  3. go again to CLI from early-startup without startup-sequence
  4. type "WhichAmiga" and check your ReKicked ROM version.
     
Sample video: EXTERNAL LINK       
     
If it shows 45.57 (Kickstart 3.9) your AmigaOS_ROM_Update is patched successfully and issue is in your OS39 installation.
     
If it does not show 45.57 (Kickstart 3.9) your AmigaOS_ROM_Update is NOT patched successfully.
     
If you think that both are ok, then issue is in your Amiga HW. If possible, test your Vampire in another recaped Amiga with the good PSU.


Leigh Russ

Posts 11
30 Jan 2017 14:34


Surely the fact that GOLD1 core works perfectly fine rules it out as a hardware issue. GOLD1 boots fine every time, both from a power on and a soft reset, both with or without the ROM update.

GOLD2 however only boots with no ROM update (have tried both 1.1 and 1.2 patched ROMS and neither work, just black screen). If booting with no ROM update, it only seems to boot reliably from a full power up and not a soft reset. Also when it does power up, probably 3 out of 4 times, the RYS MK2 mouse adapter doesn't work. This again works every time without an issue on GOLD1.

As for the for the ROM patching, this appears all OK. So as GOLD1 is perfectly fine I would of thought this is related to GOLD2 rather than hardware.



Chris Holzapfel

Posts 29
31 Jan 2017 20:54


Thank you Simo. Found my mistake in startup-sequence. Removed shapeshifer prepareemul statement. it prevented the machine from booting up. Worked until Gold1 though, so there should be a change in Apollo Core2 so prepareeuml couldnt allocate lower memory anymore. Could be solved with MuMove4K, but I did not try yet.


Gunnar von Boehn
(Apollo Team Member)
Posts 2951
01 Feb 2017 15:51


Chris Holzapfel wrote:

Thank you Simo. Found my mistake in startup-sequence. Removed shapeshifer prepareemul statement. it prevented the machine from booting up. Worked until Gold1 though, so there should be a change in Apollo Core2 so prepareeuml couldnt allocate lower memory anymore. Could be solved with MuMove4K, but I did not try yet.

Hallo Chris,

I think its the other way around...
You do not need prepeareamul on GOLD2.
So running it is not working and not helping.


Chris Holzapfel

Posts 29
01 Feb 2017 18:28


Hi, Gunnar, yes, thats what I meant. I removed the Statement and Gold2 Core is booting properly now (and only without it).


Leigh Russ

Posts 11
19 Feb 2017 13:31


After much tinkering across 3 different Amigas I  currently have this running fairly well. Still not as reliable booting with GOLD2 with the 1.2 patch and sometimes hangs else it's been running syspeed tests all ok when it has booted.

Sanded the socket down quite a bit which helped, the main change that sorted it was to remove the plastic mounts totally. Now just got to design a and print something else to mount it. One side sits lower than the other so think the mounts being the same height makes the connection a bit skewed.

Cheers guys, now to find some time to play with it


Simo Koivukoski
(Apollo Team Member)
Posts 263
24 Feb 2017 06:40


Installing AmigaOS 3.9 BB2 using WinUAE then moving CF to Vampire:

EXTERNAL LINK


Mr-Z EdgeOfPanic

Posts 143
24 Feb 2017 19:37


Nice tut, should be useful for a lot of users!


Pedro Cotter

Posts 44
07 Mar 2017 11:24


Hello,
 
  What is the best practice for GOLD2?
  Do still need the  BB2 Rom Update? Why use it?
  Doesn't  the new 3.10 Rom already have all the patches from BB2?
 
  Thank you..

posts 59page  1 2 3