Overview Features Instructions Performance Forum Downloads Products Reseller Contact

Welcome to the Apollo Forum

This forum is for people interested in the APOLLO CPU.
Please read the forum usage manual.
VISIT APOLLO IRC CHANNEL



All TopicsNewsPerformanceGamesDemosApolloVampireCoffinReleases
Performance and Benchmark Results!

FASTIDE On V500

Gunnar von Boehn
(Apollo Team Member)
Posts 3431
06 Mar 2018 00:12


Dear users please mind the following:
 
The SAGA chipset included in the V500 comes with an IDE connector.
If you enable FAST-IDE you should be able to reach 10-12 MB/sec read speed.

So do not forget to turn on FAST-IDE!


Michael R

Posts 255
06 Mar 2018 02:50


That's good to know. Thanks for the information.


Mallagan Bellator

Posts 349
06 Mar 2018 05:34


Does this apply to hard drives and CD roms too?


Henryk Richter

Posts 77
06 Mar 2018 06:09


Mallagan Bellator wrote:

Does this apply to hard drives and CD roms too?

FastIDE applies to CF-Cards (_very_ rarely also other media) and requires the CF-Card to be the only connected device.

Don't use it in master/slave mode where two devices share the IDE bus.


Istvan Hegedus

Posts 5
08 Mar 2018 07:39


I have a V500 V2+ in my A2000 with an SD2IDE adapter. I am using Gold 2.7 on it and when I enable the FastIDE feature I experience checksum errors on disk and random lockups freezes. Sometimes the RTG screen flashes. It seems FastIDE is unusable on my system. Is it possible that this feature is not compatible with my SD2IDE adapter?


Gunnar von Boehn
(Apollo Team Member)
Posts 3431
08 Mar 2018 08:16


Istvan Hegedus wrote:

I have a V500 V2+ in my A2000 with an SD2IDE adapter.

Hello Istvan,

According to the "official" specification of IDE/ATAPI devices,
this "FAST-IDE" mode that we support, is originally only supported by CF-Cards - and only for a setup with direct connection of 1 device (not 2) on the cable.

So if you use normal Harddrives or SDCards I might work by chance - but this is not guaranteed.



Istvan Hegedus

Posts 5
08 Mar 2018 08:20


Thanks Gunnar for the information. It was my guess also. Probably I should change to CF.



Steven Lyon

Posts 26
26 Mar 2018 10:18


I've only had my card for a few days so please forgive the dumb question but how do I turn this on please?


Shane Stringer

Posts 11
26 Mar 2018 10:46


From the CLI, "VControl ID 1"


Steven Lyon

Posts 26
27 Mar 2018 13:07


Thanks - is that a permanent change or do I need to enable it every time I re-boot (ie put it in user-startup)?

Are there any other 'hidden' features like this that I'm missing out on?


Roy Gillotti

Posts 193
27 Mar 2018 13:13


Steven Lyon wrote:

Thanks - is that a permanent change or do I need to enable it every time I re-boot (ie put it in user-startup)?
 
  Are there any other 'hidden' features like this that I'm missing out on?

yeah CoffinOS has a vcontrol line in the startup-sequence you can add this to, I suppose user-startup would work as well.

You can see all the features that can be enabled or disabled by running vcontrol without any flags in the shell.

posts 11