Overview Features Instructions Performance Forum Downloads Products OrderV4 Reseller Contact

Welcome to the Apollo Forum

This forum is for people interested in the APOLLO CPU.
Please read the forum usage manual.



All TopicsNewsPerformanceGamesDemosApolloVampireAROSWorkbenchATARIReleases
Questions and Answers for using ATARI TOS / FREE MINT

Vampire and EmuTOS Updates

Michael Farrell

Posts 18
08 Apr 2020 22:06


Hi all, probably a minority question,
but,
is there a way to flash a newer EmuTOS to the Vampire II without having to wait for a new core release, similar to using VampireFlash314 to load a new kickstart?

Or even load it via maprom?


Olivier Landemarre

Posts 105
09 Apr 2020 16:09


Michael Farrell wrote:

Hi all, probably a minority question,
  but,
  is there a way to flash a newer EmuTOS to the Vampire II without having to wait for a new core release, similar to using VampireFlash314 to load a new kickstart?
 
  Or even load it via maprom?

You can use an unofficial Emutos version for Amiga I have build, the 3 ST resolution are supported, for the moment black and white resolution is blinking if it has not been fixed. But don't expect as it is use game for ST! But it is a first step.

EXTERNAL LINK 
There is a maprom version for Emutos (don't work from Mint) I don't if it is what you are expecting?

Olivier



Vojin Vidanovic

Posts 1731
09 Apr 2020 16:57


Michael Farrell wrote:

Hi all, probably a minority question,
  but,
  is there a way to flash a newer EmuTOS to the Vampire II without having to wait for a new core release

EmuTOS exists as Amiga compatibile kickstart that can be used with Vamps.

Last official is 0.9.12
EXTERNAL LINK 
Latest beta snapshot exists as Amiga floppy too
EXTERNAL LINK


Olivier Landemarre

Posts 105
09 Apr 2020 21:18


Olivier Landemarre wrote:

 
Michael Farrell wrote:

  Hi all, probably a minority question,
    but,
    is there a way to flash a newer EmuTOS to the Vampire II without having to wait for a new core release, similar to using VampireFlash314 to load a new kickstart?
   
    Or even load it via maprom?
 

 

 
  You can use an unofficial Emutos version for Amiga I have build, the 3 ST resolution are supported, for the moment black and white resolution is blinking if it has not been fixed. But don't expect as it is use game for ST! But it is a first step.
 
  EXTERNAL LINK   
  There is a maprom version for Emutos (don't work from Mint) I don't if it is what you are expecting?
 
  Olivier
 
 


  I just forgot to said it is Vampire only version
 
  Olivier
 


Vojin Vidanovic

Posts 1731
10 Apr 2020 08:32


Olivier Landemarre wrote:

  I just forgot to said it is Vampire only version
 
  Olivier
 

Big thanks Olivier, keep introducing ST-STE native support. Hope Yamaha and Blitter could fit V4 core making compatibility better then Mint (Amiga counterpart would be like using just WB and RTG apps on OS4 with no emulation - you can run OS clean apps but nothing banging the chipset. That just isnt it).


Michael Farrell

Posts 18
10 Apr 2020 21:10


Hi guys, thanks for the replies.

Sorry, I should have been clearer:
Is there a way for flash another emutos to the vampire II, keeping the kickstart 3.1.4 I have on there already, but replacing the 0.9.12 that came with the last 2.12 rev2 core.

EG, can I use the snapshot rom from EXTERNAL LINK (and nott he floppy image, the rom image) and use vampireflash314 to upload it to the VampireII.


Vojin Vidanovic

Posts 1731
11 Apr 2020 16:07


Michael Farrell wrote:

  EG, can I use the snapshot rom from EXTERNAL LINK (and nott he floppy image, the rom image) and use vampireflash314 to upload it to the VampireII.
 

 
  Yes, but you would effectively loose chance to boot AmigaOS afterwards.Only USB Blaster could save the day afterwards.
 
  I propose soft kicking for one boot instead of full flash (mapROM tool).

posts 7