Overview Features Instructions Performance Forum Downloads Products Reseller Contact

Welcome to the Apollo Forum

This forum is for people interested in the APOLLO CPU.
Please read the forum usage manual.
VISIT APOLLO IRC CHANNEL



All TopicsNewsPerformanceGamesDemosApolloVampireCoffinReleases
The team will post updates and news here

Powersupply.page  1 2 

Martin Soerensen

Posts 212
14 May 2018 13:26


Roger Simons wrote:

I was using the 2,5 Amp PSU and I did find some stability issues. Switched to 4,5 Amp PSU, problems solved.
 
I had some freezes and the screen would go black every now and than.

Could well be down to the voltage of the 5V rail being different on those two supplies. Having 4.8V inside the Amiga can mean a world of difference to only having 4.7V and that voltage is not necessarily related to the wattage of the PSU, but probably more down to component tolerances. A good 2.5A PSU should be powerful enough to run a Vampire system (I have a 2.5A standard PSU which can run my V600 machine just fine), provided there are no other power-hungry additions to that machine (a CF card is not power-hungry so that is fine :)).

Marlon Beijer wrote:

Tim D wrote:

Gunnar von Boehn wrote:

Getting new reliable PSU, like a RT65-B meanwhell would ensure a stable setup.

Thanks Gunnar! Is there an easy (meaning no soldering) way to connect this to an A500, i.e. is there some adapter cable available somewhere?

EXTERNAL LINK + cable from Amiga PSU

The Meanwell PSU is not an ATX PSU, so that adapter will not be of much use in this case.


Marlon Beijer

Posts 118
14 May 2018 13:38


Martin Soerensen wrote:

  The Meanwell PSU is not an ATX PSU, so that adapter will not be of much use in this case.

Ah, in that case, ignore what I wrote.


T D

Posts 8
14 May 2018 20:30


Thanks Martin, that seems doable, even for me :)

posts 23page  1 2