Overview Features Coding Performance Forum Downloads Products OrderV4 Contact

Welcome to the Apollo Forum

This forum is for people interested in the APOLLO CPU.
Please read the forum usage manual.



All TopicsNewsPerformanceGamesDemosApolloVampireAROSWorkbenchATARIReleases
The team will post updates and news about our project here

Apollo V2 Accelerators Support Statementpage  1 2 

Bartek Kuchta

Posts 44
02 Feb 2022 12:50



   
Dear V2 users,

Apollo V2-series have been an extremely successful and hugely loved Amiga accelerator since 2014.

Vast amounts of Amiga’s were resurrected from a lonely existence in the attic by “Vampirising” with the V2-600, V2-500 and V2-1200 cards featuring the powerful AMMX 68080 CPU.

Last year the Apollo Team declared the V2 accelerators End-of-Sale and introduced the new V4 range for Amiga 500/1000/2000 (Firebird), Amiga 1200 (Icedrake) and Amiga 4000 (Kraken).

In this Support Statement we want to give full clarity to our Apollo Vampire V2 user base about the end of the Roadmap for the Apollo V2 accelerators.

Fixes:

Apollo Team has always been and will always be 100% focused on compatibility, giving our users the best Amiga experience.

We continue to collect, analyse and mitigate reported issues from our users, specifically any experiences in game & demo incompatibilities. The recent maintenance v2.15 ApolloCore release for all V2-series shows our commitment and loyalty to V2 community.

For the foreseeable future the Apollo Team will keep bringing new “maintenance” ApolloCore release to V2 accelerators.

Features:

The physical limits of the possibilities in the V2-Series FPGA have been reached. This means the current functionality will be frozen, including the support for targeted OS platforms.

In practice, this means there are no new features to be expected. The V2 range will NOT support any other OS than Amiga OS3.x. Users that want to experience all new developments in ApolloOS, including the ApolloBoot multi-OS solution running up to 10 operating systems, are encouraged to look at the new Apollo V4 accelerators.

We hope that this Support Statement gives the needed clarity on the remaining Roadmap for the V2 accelerators. Please give us your feedback or tips for bug-fixes on the Apollo Discord channel: v2-series.

Your Apollo Team


Nick Fellows

Posts 164
02 Feb 2022 16:03


Please clarify what is meant by this?

"The V2 range will NOT support any other OS than Amiga OS3.x. "

Does this mean the V2 range will NOT support Aros and ApolloOs ?




Willem Drijver
(Apollo Team Member)
Posts 119
02 Feb 2022 16:29


Correct. ApolloCore v2.15 for V2-series is AmigaOS Kickstart based and targeted for use with AmigaOS 3.x.



Peter Heginbotham

Posts 214
02 Feb 2022 20:54


Will the SAGA drivers also be split into V2 and V4 only releases?


Sean Sk

Posts 481
02 Feb 2022 21:49


Peter Heginbotham wrote:

Will the SAGA drivers also be split into V2 and V4 only releases?

Although I'm not on the team and can't comment definitively, I'd say it's likely that they'll continue to incorporate drivers for both V2 and V4 into the one installer for the foreseeable future.

Thanks Bartek for the update and thanks to the Apollo Team for the latest V2 core. Some really good progress has been made with this maintenance release.


Ian Parsons

Posts 230
03 Feb 2022 01:04


Bartek Kuchta wrote:
The V2 range will NOT support any other OS than Amiga OS3.x. Users that want to experience all new developments in ApolloOS, including the ApolloBoot multi-OS solution running up to 10 operating systems, are encouraged to look at the new Apollo V4 accelerators.

This is a strange statement, hardware doesn't usually support an OS. The OS is either adapted to support the hardware or it isn't. If the ApolloOS developers have chosen not to support the V2 range because of the extra work involved or for some other reason like the constraints of the platform that is reasonable given the resources they have and the age of the V2s. It's common to see older hardware lose support from newer versions of operating systems on other platforms like Windows and Android as they get more resource hungry and exploit newer hardware features, but with the exception of 3.5 and 3.9 Amiga OS has always supported the whole Amiga family without much restriction. I hope this isn't a sign of the future for ApolloOS with regular hardware obsolescence being created by newer releases.


Andrew Miller

Posts 352
03 Feb 2022 08:01


What about the V1200V2?


Nick Fellows

Posts 164
03 Feb 2022 08:05


Make a copy of this post , its liable to be deleted for telling the truth.


Gunnar von Boehn
(Apollo Team Member)
Posts 5933
03 Feb 2022 08:49


nick fellows wrote:

Make a copy of this post , its liable to be deleted for telling the truth.

I have the feeling that you have some passiv agression in your statements. How about we both clear this up? Please ping me on PM



Nick Fellows

Posts 164
03 Feb 2022 11:02


Im coding during the day, but i did respond to you on discord last night. Ill check again later on today.


Peter Heginbotham

Posts 214
03 Feb 2022 21:05


The reason for askingn is newer versions of the saga after 2.5.1 broke on the V2 range as the where more geared to the V4 range.


Aksel Andersen

Posts 119
04 Feb 2022 10:22


Willem Drijver wrote:

Correct. ApolloCore v2.15 for V2-series is AmigaOS Kickstart based and targeted for use with AmigaOS 3.x.
 

I dont understand... why would this hinder the v2 in running ApolloOS (AROS Fork)
Is the ApolloOS ROM to big for the v2?


Gunnar von Boehn
(Apollo Team Member)
Posts 5933
04 Feb 2022 12:49


Aksel Andersen wrote:

I dont understand... why would this hinder the v2 in running ApolloOS

You can already run ApolloOS on V2 today.

Put testing all possible configuration of A500 revision and chipsets, of all A2000 revisions and chipsets, all A600 revision and chipsets, all A1200 revisions and chipsets and also test possible expansions like e.g. PCMCIA A600 cards all together with the OS - does take a lot of time.

As this amount of worktime is currently not there - Willem made it clear that he can not promise this as delivery.

 


Aksel Andersen

Posts 119
04 Feb 2022 13:01


Gunnar von Boehn wrote:

Aksel Andersen wrote:

  I dont understand... why would this hinder the v2 in running ApolloOS
 

 
  You can already run ApolloOS on V2 today.
 
  Put testing all possible configuration of A500 revision and chipsets, of all A2000 revisions and chipsets, all A600 revision and chipsets, all A1200 revisions and chipsets and also test possible expansions like e.g. PCMCIA A600 cards all together with the OS - does take a lot of time.
 
  As this amount of worktime is currently not there - Willem made it clear that he can not promise this as delivery.
 
 
 

great.. thanks for the clarification..

I have been compiling and running ApolloOS for the v2 since the sources was out.. havent dealt with it in a while.. was waiting it to mature a little bit more (And boy it have since the last time... great work)



Patrick Nevian

Posts 8
07 Feb 2022 00:49


Haven´t checked the release candidate yet.
But I hope the fixes also help with these games:
EXTERNAL LINK 
THX!


Sean Sk

Posts 481
07 Feb 2022 12:35


Hi Patrick,
 
I tried all three games and they appeared to work fine on the V1200 with Gold 2.15 core. Granted, I've never played these particular games before, so half the time I didn't kow what I was doing. :D
 
Epic: Both space and planetary missions seemed to work.
Jurassic Park: Played fine, although I didn't progress beyond the first level as I had no idea what I was doing.
Virtual Karting: Also played without a hitch.
 
I didn't use any tooltyps with these games either.
 
It's worth the effort to update to Gold 2.15. I've personally found it pretty good to use so far.
 
As a side note, I'd never seen Epic before. It's a good looking game!! I really enjoyed it, but I did laugh hard at all it's blatant plagiarising of Star Wars, Battlestar Galactica and Star Trek. :D


Patrick Nevian

Posts 8
07 Feb 2022 16:20


@Sean Sk:

Thanks a lot for your info.
Great news.

Yes, I will try the new core some time soon.



Patrick Nevian

Posts 8
07 Feb 2022 19:00


Virtual Karting and Epic now work thanks to the new core.
 
  BUT:
 
  Jurassic Park AGA 3D sections still crash with "cache".
  Without it´s sooo slow.
 
  This really needs a fix.
  Try this password and test it:  E54C67AA
 


Sean Sk

Posts 481
08 Feb 2022 12:08


Patrick Nevian wrote:

Jurassic Park AGA 3D sections still crash with "cache".
Without it´s sooo slow.

Yes I can confirm this as well.


Patrick Nevian

Posts 8
08 Feb 2022 18:05


@ Apollo team:
 
  To be honest, this really should work.
  Especially because it´s the WHDload version.
 
  Please focus on more compatibility.
  Thanks. :)

posts 30page  1 2