Overview Features Instructions Performance Forum Downloads Products OrderV4 Reseller Contact

Welcome to the Apollo Forum

This forum is for people interested in the APOLLO CPU.
Please read the forum usage manual.



All TopicsNewsPerformanceGamesDemosApolloVampireAROSWorkbenchATARIReleases
The team will post updates and news here

Vampire V2 Is Now AmigaOS 3.1.4 Readypage  1 2 3 4 5 6 7 8 9 

Gunnar von Boehn
(Apollo Team Member)
Posts 5011
27 Jan 2019 18:29


Chris T. wrote:

I guess you have to get the library "libs 040/060 from aminet.net and copy it to libs...

Vampire does NOT need those.
The 68080 is more complete than 68040/68060 and works fine without these helper libs.


Willem Drijver

Posts 78
27 Jan 2019 19:25


Thanks Gunnar, that is what I thought. So this means I can just ignore the error message from the "CPU checkinstall" in the startup-sequence?


Vojin Vidanovic

Posts 1735
27 Jan 2019 20:46


Willem Drijver wrote:

  Thanks Gunnar, that is what I thought. So this means I can just ignore the error message from the "CPU checkinstall" in the startup-sequence?
 

 
  Yes, message is intended to real 040/060 users. Hyperion missed to integrate 080 ID and our CPU is seen as 040, but it does not need a patching libs.


Lars Simonsen

Posts 1
05 Feb 2019 18:12


sean sk wrote:
That's good to know the latest version of KS 3.1.4 works with VampireFlash314.

(Updated post) I received my Vampire A600 today so I bought KS 3.1.4 for A1200 (per Hyperion's recommendation) and downloaded it.
     
VampireMap315 and VampireFlash314 both told me that the checksum is wrong, trying to flash the unsplit file.
     
      vampiremap314 devs:kickstarts/kick.a1200.46.143
      Error. Input Kickstart checksum wrong.
      Kickstart file integrity check failed
      Exiting.
 
It must have been the SD card or PCMCIA adapter that I used to transfer the file that had corrupted the ROM, because I deleted the ROM file and transfered it from my Windoze machine again, and lo and behold - now it works.


Vojin Vidanovic

Posts 1735
06 Feb 2019 14:42


Lars Simonsen wrote:

  It must have been the SD card or PCMCIA adapter that I used to transfer the file that had corrupted the ROM, because I deleted the ROM file and transfered it from my Windoze machine again, and lo and behold - now it works.

Changing any bit of Amiga file can cause such trouble. Not the first time. Glad "its Vamp ready" (which is compatibile, not optimized)



Stefano Briccolani

Posts 517
03 Aug 2019 22:58


I tried to make a bootdisk to load 0s3.1.4 roms before installing the floppys. I put kick.1200 rom and Vampiremap314 on the root of floopy. Then i wrote a minimal startup-sequence like: vampiremap314 kick.1200 but When I boot from that disk, after a brief load I get an "vampiremap314 failed returncode 20".



Stefano Briccolani

Posts 517
04 Aug 2019 17:39


Ok, I managed to get os3.1.4.1 installed on my vampire 600 v2 using a cusomized 3.1.4 kick.a1200 rom that includes the new intuition library, and new fastfilesystem, shell seg and audio device. The system start and works with new picasso96,saga driver and bestwb 1.2 on top.
The only problem is that this system doesn't find the fpu. I'm missing something? I didn't install mmulib because I saw a post of Shk on eab that said that 68060 library is not necessary on vampire..


Vojin Vidanovic

Posts 1735
05 Aug 2019 18:30


Os 3.1.4 Is just bugfixed os3.1, not advancement over os3.5/os3.9 with exception of few things, date and company details. So, as 3.1 is 00-020 optimized and does not really see beyond 030 with no additional software
 
  But, try some 040-fpu binaries


Kamelito Loveless

Posts 130
06 Aug 2019 21:40


https://forum.amiga.org/index.php?topic=73694.msg840541#msg840541



Kamelito Loveless

Posts 130
06 Aug 2019 21:41


Double post


Stefano Briccolani

Posts 517
07 Aug 2019 06:20


No way, I installed the mmulib package from Aminet and now I have a 68060.library in libs: , but.still no FPU.
So the problem could be core-related (i didn't try with 2.12RC maybe that can solve) or kickstart related (i made a custom kick.a1200 that includes new intuition.library, audio.device, shell seg and fastfilesystem taken from the 3.1.4.1 update using romsplit and remus)


Stefano Briccolani

Posts 517
08 Aug 2019 21:53


Tried with official 3.1.4 rom (without any remus manipulation). Same results. The FPU is not available. Is there anyone that have successfully done a 3.1.4.1 installation on a v600 with core 2.11? Maybe i missed something..


Vojin Vidanovic

Posts 1735
08 Aug 2019 23:44


Gunnar von Boehn wrote:

  Vampire does NOT need those.
  The 68080 is more complete than 68040/68060 and works fine without these helper libs.

Even asking for 040.library seems to be resolved with GOLD2.12 RC2, great works, feels you get into end users bones!


Stefano Briccolani

Posts 517
09 Aug 2019 16:55


This Mr. Vojin guy closes all my posts with cuts from Gunnar or other apollo guy's statements. (Something I can read for myself) Is he an Apollo team member?
Maybe he's a kind of web-guard. Don't need it in an hobby project.


Sean Sk

Posts 383
10 Aug 2019 00:58


Stefano Briccolani wrote:

Tried with official 3.1.4 rom (without any remus manipulation). Same results. The FPU is not available. Is there anyone that have successfully done a 3.1.4.1 installation on a v600 with core 2.11? Maybe i missed something..

 
Hi Stefano. Yes I have the same setup and I didn't really have to do anything out of the ordinary. FPU in the core is detected by the OS.
 
I originally had an OS 3.1 installation and installed OS 3.1.4 straight over the top.
 
Prior to the 3.1.4 upgrade, I renamed "kick.a1200.46.143" to "kick.a1200" and put it into DEVS:Kickstarts/ since I had already created that folder for WHDLoad. I also put VampireFlash314 into C.
 
Rebooted and went into early startup menu and selected "Boot With No Startup-Sequence". Once booted I typed "VampireFlash314 DEVS:Kickstarts/kick.a1200". Flashing the new kickstart into the V600 worked.
 
Once that was done, then I went ahead with installing OS 3.1.4 over the top of my 3.1 installation. Then after that I installed the 3.1.4.1 update.
 
I didn't have to include any special libraries to get the FPU to be detected. It just works and I confirmed it was detected via Sysinfo.
 
I know you probably have tried all of this already so don't really know what other advice to give. The only difference with me is I didn't create a custom kickstart.
 
Stefano Briccolani wrote:

This Mr. Vojin guy closes all my posts with cuts from Gunnar or other apollo guy's statements. (Something I can read for myself) Is he an Apollo team member?

 
No. Just an over-enthusiastic member of the forum. Wouldn't hurt a fly. We need more people like him. :)


Stefano Briccolani

Posts 517
10 Aug 2019 07:14


I tried even with standard 3.1.4 kickstart. no fpu.
Have you loaded the new intuition library whit loadmodule on startup? A difference is that I used the maprom function, you seem to have flashed the rom.


Stefano Briccolani

Posts 517
10 Aug 2019 15:09


Tried with core 2.12 RC2. Same results. System works perfectly but no FPU. When I switch back to Coffin and vampire built-in roms (no vampiremaprom in startup sequence) the FPU came back and works Ok, so it seems a software problem or a maprom one. I didn't remove phisical roms from my amiga600.

UPDATE: I removed the Loadmodule rompupdate from startup-sequence (so no windows dragging out of screen) so with original and untouched a1200 3.1.4 roms. FPU is missing.
 


Vojin Vidanovic

Posts 1735
10 Aug 2019 15:57


sean sk wrote:

   
Stefano Briccolani wrote:

    This Mr. Vojin guy closes all my posts with cuts from Gunnar or other apollo guy's statements. (Something I can read for myself) Is he an Apollo team member?

   
    No. Just an over-enthusiastic member of the forum. Wouldn't hurt a fly. We need more people like him. :)
 

 
  True, true, true, thanks
 
  Note that Real team members, like Gunnar and Flype or Tuko - have "Apollo team members" tag under name.


Stefano Briccolani

Posts 517
10 Aug 2019 16:52


Vojin Vidanovic wrote:

 
sean sk wrote:

     
Stefano Briccolani wrote:

      This Mr. Vojin guy closes all my posts with cuts from Gunnar or other apollo guy's statements. (Something I can read for myself) Is he an Apollo team member?

     
      No. Just an over-enthusiastic member of the forum. Wouldn't hurt a fly. We need more people like him. :)
   

   
    True, true, true, thanks
   
    Note that Real team members, like Gunnar and Flype or Tuko - have "Apollo team members" tag under name.
 

 
  Ok, maybe I was a bit rude. But if you state something as a true fact and not as an opinion, people read the post and say.. ok, problem solved. Some time ago I asked for news about the v1200. You replied that fist of all will come the v4 standalone (I am not so convinced about that). From the tone of that reply you can assume it's an official statement from the team, intstead is only your opinion (as is mine that v1200 will come out before v4 standalone). BUT your reply seemed like an official apollo team's one and nobody argued. Didn't want to hurt anyone's passion. So excuse me if my comment was a bit harsh. Just putting the words "in my opinion" before your posts can help to clarify. Ciao


Vojin Vidanovic

Posts 1735
11 Aug 2019 04:05


Stefano Briccolani wrote:

    So excuse me if my comment was a bit harsh. Just putting the words "in my opinion" before your posts can help to clarify. Ciao
 

 
  Its always an opinion, formed on what I can read. V1200 is side project, a labor of love of Majsta again and is kind of "side effect". Standalone is the thing.some time after sa v4 1200 will appear with full core3 saga, 512 MB faster ram and a bit higher clock CPU and that will be Real high end a1200 upgrade. This one I expect to be made in smaller batches and just for those eho cant wait.I admire majstas sucess, but itd just a1200 catch up to v2 vamp gen.
 
  I agree I tend to cut it short in phrasing, not using "In my opinion", "Based on my belief" or "based on what I have read or heard by now"
 

posts 165page  1 2 3 4 5 6 7 8 9